GHSA-qhxx-j73r-qpm2 BIT-tensorflow-2020-26266 CVE-2020-26266 PYSEC-2020-254 PYSEC-2020-297 PYSEC-2020-332
Uninitialized memory access in TensorFlow
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 0.26%
- Chance of exploitation in the next 30 days. Higher than 17.98% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-908 Use of Uninitialized Resource
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
Under certain cases, a saved model can trigger use of uninitialized values during code execution. This is caused by having tensor buffers be filled with the default value of the type but forgetting to default initialize the quantized floating point types in Eigen:
struct QUInt8 {
QUInt8() {}
// ...
uint8_t value;
};
struct QInt16 {
QInt16() {}
// ...
int16_t value;
};
struct QUInt16 {
QUInt16() {}
// ...
uint16_t value;
};
struct QInt32 {
QInt32() {}
// ...
int32_t value;
};
Patches
We have patched the issue in GitHub commit ace0c15a22f7f054abcc1f53eabbcb0a1239a9e2 and will release TensorFlow 2.4.0 containing the patch. TensorFlow nightly packages after this commit will also have the issue resolved.
Since this issue also impacts TF versions before 2.4, we will patch all releases between 1.15 and 2.3 inclusive.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 1.15.5 |
1.15.5 |
| tensorflow | >= 2.0.0, < 2.0.4 |
2.0.4 |
| tensorflow | >= 2.1.0, < 2.1.3 |
2.1.3 |
| tensorflow | >= 2.2.0, < 2.2.2 |
2.2.2 |
| tensorflow | >= 2.3.0, < 2.3.2 |
2.3.2 |
| tensorflow | < 1.15.5>= 2.0.0, < 2.0.4>= 2.1.0, < 2.1.3>= 2.2.0, < 2.2.2>= 2.3.0, < 2.3.2 |
1.15.52.0.42.1.32.2.22.3.2 |
| tensorflow-cpu | < 1.15.5 |
1.15.5 |
| tensorflow-cpu | >= 2.0.0, < 2.0.4 |
2.0.4 |
| tensorflow-cpu | >= 2.1.0, < 2.1.3 |
2.1.3 |
| tensorflow-cpu | >= 2.2.0, < 2.2.2 |
2.2.2 |
| tensorflow-cpu | >= 2.3.0, < 2.3.2 |
2.3.2 |
| tensorflow-cpu | < 1.15.5>= 2.0.0, < 2.0.4>= 2.1.0, < 2.1.3>= 2.2.0, < 2.2.2>= 2.3.0, < 2.3.2 |
1.15.52.0.42.1.32.2.22.3.2 |
| tensorflow-gpu | < 1.15.5 |
1.15.5 |
| tensorflow-gpu | >= 2.0.0, < 2.0.4 |
2.0.4 |
| tensorflow-gpu | >= 2.1.0, < 2.1.3 |
2.1.3 |
| tensorflow-gpu | >= 2.2.0, < 2.2.2 |
2.2.2 |
| tensorflow-gpu | >= 2.3.0, < 2.3.2 |
2.3.2 |
| tensorflow-gpu | < 1.15.5>= 2.0.0, < 2.0.4>= 2.1.0, < 2.1.3>= 2.2.0, < 2.2.2>= 2.3.0, < 2.3.2 |
1.15.52.0.42.1.32.2.22.3.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 1.15.5
- pip
pip install --upgrade "tensorflow>=1.15.5"- poetry
poetry add "tensorflow>=1.15.5"- uv
uv add "tensorflow>=1.15.5"
tensorflow-cpu PyPI → 1.15.5
- pip
pip install --upgrade "tensorflow-cpu>=1.15.5"- poetry
poetry add "tensorflow-cpu>=1.15.5"- uv
uv add "tensorflow-cpu>=1.15.5"
tensorflow-gpu PyPI → 1.15.5
- pip
pip install --upgrade "tensorflow-gpu>=1.15.5"- poetry
poetry add "tensorflow-gpu>=1.15.5"- uv
uv add "tensorflow-gpu>=1.15.5"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N
- Attack vector
- Local
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- Low
- Availability (vulnerable system)
- Low
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 4.4
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- Low
- Availability
- Low
Weakness
CWE-908: Use of Uninitialized Resource
The product uses or accesses a resource that has not been initialized.
How to prevent it
- Implementation: Explicitly initialize the resource before use. If this is performed through an API function or standard procedure, follow all required steps.
- Implementation: Pay close attention to complex conditionals that affect initialization, since some branches might not perform the initialization.
- Implementation: Avoid race conditions (CWE-362) during initialization routines.
- Build and Compilation: Run or compile the product with settings that generate warnings about uninitialized variables or data.
References
Advisories
Packages
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-qhxx-j73r-qpm2
- github.com/tensorflow/tensorflow/commit/ace0c15a22f7f054abcc1f53eabbcb0a1239a9e2
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-297…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-332…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-254.yaml
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor