GHSA-qh32-6jjc-qprm BIT-tensorflow-2020-15209 CVE-2020-15209 PYSEC-2020-132 PYSEC-2020-289 PYSEC-2020-324
Null pointer dereference in tensorflow-lite
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 0.80%
- Chance of exploitation in the next 30 days. Higher than 56.60% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-476 NULL Pointer Dereference
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
A crafted TFLite model can force a node to have as input a tensor backed by a nullptr buffer. This can be achieved by changing a buffer index in the flatbuffer serialization to convert a read-only tensor to a read-write one. The runtime assumes that these buffers are written to before a possible read, hence they are initialized with nullptr:
https://github.com/tensorflow/tensorflow/blob/0e68f4d3295eb0281a517c3662f6698992b7b2cf/tensorflow/lite/core/subgraph.cc#L1224-L1227
However, by changing the buffer index for a tensor and implicitly converting that tensor to be a read-write one, as there is nothing in the model that writes to it, we get a null pointer dereference.
Patches
We have patched the issue in 0b5662bc and will release patch releases for all versions between 1.15 and 2.3.
We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by members of the Aivul Team from Qihoo 360 but was also discovered through variant analysis of GHSA-cvpc-8phh-8f45.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 1.15.4 |
1.15.4 |
| tensorflow | >= 2.0.0, < 2.0.3 |
2.0.3 |
| tensorflow | >= 2.1.0, < 2.1.2 |
2.1.2 |
| tensorflow | >= 2.2.0, < 2.2.1 |
2.2.1 |
| tensorflow | >= 2.3.0, < 2.3.1 |
2.3.1 |
| tensorflow | < 1.15.4>= 2.0.0, < 2.0.3>= 2.1.0, < 2.1.2>= 2.2.0, < 2.2.1>= 2.3.0, < 2.3.1 |
1.15.42.0.32.1.22.2.12.3.1 |
| tensorflow-cpu | < 1.15.4 |
1.15.4 |
| tensorflow-cpu | >= 2.0.0, < 2.0.3 |
2.0.3 |
| tensorflow-cpu | >= 2.1.0, < 2.1.2 |
2.1.2 |
| tensorflow-cpu | >= 2.2.0, < 2.2.1 |
2.2.1 |
| tensorflow-cpu | >= 2.3.0, < 2.3.1 |
2.3.1 |
| tensorflow-cpu | < 1.15.4>= 2.0.0, < 2.0.3>= 2.1.0, < 2.1.2>= 2.2.0, < 2.2.1>= 2.3.0, < 2.3.1 |
1.15.42.0.32.1.22.2.12.3.1 |
| tensorflow-gpu | < 1.15.4 |
1.15.4 |
| tensorflow-gpu | >= 2.0.0, < 2.0.3 |
2.0.3 |
| tensorflow-gpu | >= 2.1.0, < 2.1.2 |
2.1.2 |
| tensorflow-gpu | >= 2.2.0, < 2.2.1 |
2.2.1 |
| tensorflow-gpu | >= 2.3.0, < 2.3.1 |
2.3.1 |
| tensorflow-gpu | < 1.15.4>= 2.0.0, < 2.0.3>= 2.1.0, < 2.1.2>= 2.2.0, < 2.2.1>= 2.3.0, < 2.3.1 |
1.15.42.0.32.1.22.2.12.3.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 1.15.4
- pip
pip install --upgrade "tensorflow>=1.15.4"- poetry
poetry add "tensorflow>=1.15.4"- uv
uv add "tensorflow>=1.15.4"
tensorflow-cpu PyPI → 1.15.4
- pip
pip install --upgrade "tensorflow-cpu>=1.15.4"- poetry
poetry add "tensorflow-cpu>=1.15.4"- uv
uv add "tensorflow-cpu>=1.15.4"
tensorflow-gpu PyPI → 1.15.4
- pip
pip install --upgrade "tensorflow-gpu>=1.15.4"- poetry
poetry add "tensorflow-gpu>=1.15.4"- uv
uv add "tensorflow-gpu>=1.15.4"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- Present
- Privileges required
- None
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 5.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-476: NULL Pointer Dereference
The product dereferences a pointer that it expects to be valid but is NULL.
How to prevent it
- Implementation: For any pointers that could have been modified or provided from a function that can return NULL, check the pointer for NULL before use. When working with a multithreaded or otherwise asynchronous environment, ensure that proper locking APIs are used to lock before the check, and unlock when it has finished [REF-1484].
- Requirements: Select a programming language that is not susceptible to these issues.
- Implementation: Check the results of all functions that return a value and verify that the value is non-null before acting upon it.
- Architecture and Design: Identify all variables and data stores that receive information from external sources, and apply input validation to make sure that they are only initialized to expected values.
- Implementation: Explicitly initialize all variables and other data stores, either during declaration or just before the first usage.
References
Advisories
Packages
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-qh32-6jjc-qprm
- github.com/tensorflow/tensorflow/commit/0b5662bc2be13a8c8f044d925d87fb6e56247cd8
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-289…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-324…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-132.yaml
- github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor