GHSA-qc43-pgwq-3q2q CVE-2022-36102
Shopware access control list bypassed via crafted specific URLs
- Severity
- 6.3 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.80%
- Chance of exploitation in the next 30 days. Higher than 56.53% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-281 Improper Preservation of Permissions
- Fix
5.7.15- Upgrade shopware/shopware to this version or later
Description
Impact
If backend admin controllers are called with a certain notation, the ACL could be bypassed. Users could execute actions, which they are normally not able to do.
Patches
We recommend updating to the current version 5.7.15. You can get the update to 5.7.15 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/changelog-sw5/#5-7-15
For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
References
https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-09-2022
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| shopware/shopware | < 5.7.15 |
5.7.15 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
shopware/shopware Packagist → 5.7.15
- composer
composer require shopware/shopware:^5.7.15
Severity breakdown
CVSS 3.1 6.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Weakness
CWE-281: Improper Preservation of Permissions
The product does not preserve permissions or incorrectly preserves permissions when copying, restoring, or sharing objects, which can cause them to have less restrictive permissions than intended.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-7cw6-7h3h-v8pf Shopware Has Improper Control of Generation of Code in Twig rendered views | High | Also affects shopware/shopware |
| GHSA-6w82-v552-wjw2 Shopware Storefront Reflected XSS in Storefront Login Page | Medium | Also affects shopware/shopware |
| GHSA-9v82-vcjx-m76j Shopware: Reflective Cross Site-Scripting (XSS) in CMS components | High | Also affects shopware/shopware |
| GHSA-83jv-4prm-34g7 Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-7336-ghhp-f2qj Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-jqr7-5h7r-ch8p Shopware Non-Persistent XSS in the Frontend | Medium | Also affects shopware/shopware |
| GHSA-q3g4-2vw9-xv27 Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-gh66-fp7j-98v5 Shopware improper mail validation vulnerability | Medium | Also affects shopware/shopware |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor