GHSA-q97c-2mh3-pgw9 CVE-2023-34098
Shopware dependency configuration exposed
- Severity
- 5.3 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.61%
- Chance of exploitation in the next 30 days. Higher than 49.24% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
5.7.18- Upgrade shopware/shopware to this version or later
Description
Impact
Due to a wrong configuration in the .htaccess file, the configuration file of Javascript dependencies could be read in production environments (themes/package-lock.json). With this information, the used Shopware version might be determined by an attacker, which could be used for further attacks.
Patches
We recommend updating to the current version 5.7.18. You can get the update to 5.7.18 regularly via the Auto-Updater or directly via the release page. https://github.com/shopware5/shopware/releases/tag/v5.7.18
For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
References
https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2023
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| shopware/shopware | >= 5.6.0, < 5.7.18 |
5.7.18 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
shopware/shopware Packagist → 5.7.18
- composer
composer require shopware/shopware:^5.7.18
Severity breakdown
CVSS 3.1 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
- github.com/shopware/shopware/security/advisories/GHSA-q97c-2mh3-pgw9
- github.com/shopware5/shopware/security/advisories/GHSA-q97c-2mh3-pgw9
- github.com/shopware5/shopware/commit/b3518c8d9562a38615d638f31f79829f6e2f4b6a
- docs.shopware.com/en/shopware-5-en/security-updates/security-update-06-2023
- shopware.com/en/changelog-sw5
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-7cw6-7h3h-v8pf Shopware Has Improper Control of Generation of Code in Twig rendered views | High | Also affects shopware/shopware |
| GHSA-6w82-v552-wjw2 Shopware Storefront Reflected XSS in Storefront Login Page | Medium | Also affects shopware/shopware |
| GHSA-9v82-vcjx-m76j Shopware: Reflective Cross Site-Scripting (XSS) in CMS components | High | Also affects shopware/shopware |
| GHSA-83jv-4prm-34g7 Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-7336-ghhp-f2qj Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-jqr7-5h7r-ch8p Shopware Non-Persistent XSS in the Frontend | Medium | Also affects shopware/shopware |
| GHSA-q3g4-2vw9-xv27 Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-gh66-fp7j-98v5 Shopware improper mail validation vulnerability | Medium | Also affects shopware/shopware |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor