Skip to content

GHSA-q85f-69q7-55h2 BIT-tensorflow-2022-23573 CVE-2022-23573 PYSEC-2022-137 PYSEC-2022-82 PYSEC-2026-3229

Uninitialized variable access in Tensorflow

High PyPI
Severity
0.0 / 10
High · CVSS 4.0
Exploit chance (EPSS)
0.76%
Chance of exploitation in the next 30 days. Higher than 55.34% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-908 Use of Uninitialized Resource
Fix
Available
3 packages have a fixed version

Description

Impact

The implementation of AssignOp can result in copying unitialized data to a new tensor. This later results in undefined behavior.

The implementation has a check that the left hand side of the assignment is initialized (to minimize number of allocations), but does not check that the right hand side is also initialized.

Patches

We have patched the issue in GitHub commit ef1d027be116f25e25bb94a60da491c2cf55bd0b.

The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
< 2.5.3
2.5.3
tensorflow
>= 2.6.0, < 2.6.3
2.6.3
tensorflow
>= 2.7.0, < 2.7.1
2.7.1
tensorflow
< 2.5.3
>= 2.6.0, < 2.6.3
>= 2.7.0, < 2.7.1
2.5.3
2.6.3
2.7.1
tensorflow-cpu
< 2.5.3
2.5.3
tensorflow-cpu
>= 2.6.0, < 2.6.3
2.6.3
tensorflow-cpu
>= 2.7.0, < 2.7.1
2.7.1
tensorflow-cpu
< 2.5.3
>= 2.6.0, < 2.6.3
2.5.3
2.6.3
tensorflow-gpu
< 2.5.3
2.5.3
tensorflow-gpu
>= 2.6.0, < 2.6.3
2.6.3
tensorflow-gpu
>= 2.7.0, < 2.7.1
2.7.1
tensorflow-gpu
< 2.5.3
>= 2.6.0, < 2.6.3
2.5.3
2.6.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.5.3

pip
pip install --upgrade "tensorflow>=2.5.3"
poetry
poetry add "tensorflow>=2.5.3"
uv
uv add "tensorflow>=2.5.3"

tensorflow-cpu PyPI → 2.5.3

pip
pip install --upgrade "tensorflow-cpu>=2.5.3"
poetry
poetry add "tensorflow-cpu>=2.5.3"
uv
uv add "tensorflow-cpu>=2.5.3"

tensorflow-gpu PyPI → 2.5.3

pip
pip install --upgrade "tensorflow-gpu>=2.5.3"
poetry
poetry add "tensorflow-gpu>=2.5.3"
uv
uv add "tensorflow-gpu>=2.5.3"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
None
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
Low
Integrity (vulnerable system)
Low
Availability (vulnerable system)
High
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 7.6

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
High

Weakness

CWE-908: Use of Uninitialized Resource

The product uses or accesses a resource that has not been initialized.

How to prevent it
  • Implementation: Explicitly initialize the resource before use. If this is performed through an API function or standard procedure, follow all required steps.
  • Implementation: Pay close attention to complex conditionals that affect initialization, since some branches might not perform the initialization.
  • Implementation: Avoid race conditions (CWE-362) during initialization routines.
  • Build and Compilation: Run or compile the product with settings that generate warnings about uninitialized variables or data.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor