Skip to content

GHSA-q56r-mw39-944g CVE-2022-43690

Concrete CMS vulnerable to Improper Authentication

Medium Packagist
Severity
6.3 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
0.66%
Chance of exploitation in the next 30 days. Higher than 51.40% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-287 Improper Authentication
Fix
8.5.10
Upgrade concrete5/concrete5 to this version or later

Description

Concrete CMS (formerly concrete5) below 8.5.10 and between 9.0.0 and 9.1.2 did not use strict comparison for the legacy_salt so that limited authentication bypass could occur if using this functionality. Remediate by updating to Concrete CMS 9.1.3+ or 8.5.10+.

Affected versions

Packagist

PackageVulnerableFixed in
concrete5/concrete5
< 8.5.10
8.5.10
concrete5/concrete5
>= 9.0.0, < 9.1.3
9.1.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

concrete5/concrete5 Packagist → 8.5.10

composer
composer require concrete5/concrete5:^8.5.10

Severity breakdown

CVSS 3.1 6.3

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
Required
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
Low

Weakness

CWE-287: Improper Authentication

When an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.

How to prevent it
  • Architecture and Design: Use an authentication framework or library such as the OWASP ESAPI Authentication feature.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-g82f-9pw7-773w
Concrete CMS: PHP Object Injection via unserialize() calls
High Also affects concrete5/concrete5
GHSA-52pr-7vmf-2w7x
Concrete CMS is vulnerable to PHP Object Injection via unserialize() calls in the Workflow, Form block, and File/Set components
High Also affects concrete5/concrete5
GHSA-q9fm-mpg8-8jqm
Concrete CMS is vulnerable to Stored XSS via page name in the Atomik theme
Medium Also affects concrete5/concrete5
GHSA-jqvq-gv67-3567
Concrete CMS is vulnerable to IDOR + wrong-authorization-level in the Express association Reorder dialog
Medium Also affects concrete5/concrete5
GHSA-xjg6-5v39-v7fc
Concrete CMS is vulnerable to CSRF via Backend\File::approveVersion
Medium Also affects concrete5/concrete5
GHSA-44q4-354f-c826
Concrete CMS is vulnerable to Cross Site Request Forgery (CSRF) at concrete/controllers/backend/file approveVersion()
Medium Also affects concrete5/concrete5
GHSA-6qjh-p324-694f
Concrete CMS is vulnerable to Cross Site Request Forgery (CSRF) at concrete/controllers/backend/file rescanMultiple()
High Also affects concrete5/concrete5
GHSA-6fxm-r8p3-mx5c
Concrete CMS is vulnerable to Cross Site Request Forgery (CSRF) at concrete/controllers/backend/file rescan()
High Also affects concrete5/concrete5
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor