Skip to content

GHSA-q2c3-jpmc-gfjx BIT-tensorflow-2022-35969 CVE-2022-35969 PYSEC-2026-1028 PYSEC-2026-3227 PYSEC-2026-3360

TensorFlow vulnerable to `CHECK` fail in `Conv2DBackpropInput`

Medium PyPI
Severity
5.9 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
0.46%
Chance of exploitation in the next 30 days. Higher than 40.02% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
—
Not classified
Fix
Available
3 packages have a fixed version

Description

Impact

The implementation of Conv2DBackpropInput requires input_sizes to be 4-dimensional. Otherwise, it gives a CHECK failure which can be used to trigger a denial of service attack:

import tensorflow as tf

strides = [1, 1, 1, 1]
padding = "SAME"
use_cudnn_on_gpu = True
explicit_paddings = []
data_format = "NHWC"
dilations = [1, 1, 1, 1]
input_sizes = tf.constant([65534,65534], shape=[2], dtype=tf.int32)
filter = tf.constant(0.159749106, shape=[3,3,2,2], dtype=tf.float32)
out_backprop = tf.constant(0, shape=[], dtype=tf.float32)
tf.raw_ops.Conv2DBackpropInput(input_sizes=input_sizes, filter=filter, out_backprop=out_backprop, strides=strides, padding=padding, use_cudnn_on_gpu=use_cudnn_on_gpu, explicit_paddings=explicit_paddings, data_format=data_format, dilations=dilations)

Patches

We have patched the issue in GitHub commit 50156d547b9a1da0144d7babe665cf690305b33c.

The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by Neophytos Christou, Secure Systems Labs, Brown University.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
< 2.7.2
2.7.2
tensorflow
>= 2.8.0, < 2.8.1
2.8.1
tensorflow
>= 2.9.0, < 2.9.1
2.9.1
tensorflow
< 2.7.2
>= 2.8.0, < 2.8.1
>= 2.9.0, < 2.9.1
2.7.2
2.8.1
2.9.1
tensorflow-cpu
< 2.7.2
2.7.2
tensorflow-cpu
>= 2.8.0, < 2.8.1
2.8.1
tensorflow-cpu
>= 2.9.0, < 2.9.1
2.9.1
tensorflow-cpu
< 2.7.2
>= 2.8.0, < 2.8.1
>= 2.9.0, < 2.9.1
2.7.2
2.8.1
2.9.1
tensorflow-gpu
< 2.7.2
2.7.2
tensorflow-gpu
>= 2.8.0, < 2.8.1
2.8.1
tensorflow-gpu
>= 2.9.0, < 2.9.1
2.9.1
tensorflow-gpu
< 2.7.2
>= 2.8.0, < 2.8.1
>= 2.9.0, < 2.9.1
2.7.2
2.8.1
2.9.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.7.2

pip
pip install --upgrade "tensorflow>=2.7.2"
poetry
poetry add "tensorflow>=2.7.2"
uv
uv add "tensorflow>=2.7.2"

tensorflow-cpu PyPI → 2.7.2

pip
pip install --upgrade "tensorflow-cpu>=2.7.2"
poetry
poetry add "tensorflow-cpu>=2.7.2"
uv
uv add "tensorflow-cpu>=2.7.2"

tensorflow-gpu PyPI → 2.7.2

pip
pip install --upgrade "tensorflow-gpu>=2.7.2"
poetry
poetry add "tensorflow-gpu>=2.7.2"
uv
uv add "tensorflow-gpu>=2.7.2"

Severity breakdown

CVSS 3.1 5.9

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Attack vector
Network
Attack complexity
High
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
High

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor