Skip to content

GHSA-q263-fvxm-m5mw BIT-tensorflow-2020-26271 CVE-2020-26271 PYSEC-2020-257 PYSEC-2020-302 PYSEC-2020-337

Heap out of bounds access in MakeEdge in TensorFlow

Medium PyPI
Severity
0.0 / 10
Medium · CVSS 4.0
Exploit chance (EPSS)
0.22%
Chance of exploitation in the next 30 days. Higher than 12.07% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-125 Out-of-bounds Read
CWE-908 Use of Uninitialized Resource
Fix
Available
3 packages have a fixed version

Description

Impact

Under certain cases, loading a saved model can result in accessing uninitialized memory while building the computation graph. The MakeEdge function creates an edge between one output tensor of the src node (given by output_index) and the input slot of the dst node (given by input_index). This is only possible if the types of the tensors on both sides coincide, so the function begins by obtaining the corresponding DataType values and comparing these for equality:

  DataType src_out = src->output_type(output_index);
  DataType dst_in = dst->input_type(input_index);
  //...

However, there is no check that the indices point to inside of the arrays they index into. Thus, this can result in accessing data out of bounds of the corresponding heap allocated arrays.

In most scenarios, this can manifest as unitialized data access, but if the index points far away from the boundaries of the arrays this can be used to leak addresses from the library.

Patches

We have patched the issue in GitHub commit 0cc38aaa4064fd9e79101994ce9872c6d91f816b and will release TensorFlow 2.4.0 containing the patch. TensorFlow nightly packages after this commit will also have the issue resolved.

Since this issue also impacts TF versions before 2.4, we will patch all releases between 1.15 and 2.3 inclusive.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
< 1.15.5
1.15.5
tensorflow
>= 2.0.0, < 2.0.4
2.0.4
tensorflow
>= 2.1.0, < 2.1.3
2.1.3
tensorflow
>= 2.2.0, < 2.2.2
2.2.2
tensorflow
>= 2.3.0, < 2.3.2
2.3.2
tensorflow
< 1.15.5
>= 2.0.0, < 2.0.4
>= 2.1.0, < 2.1.3
>= 2.2.0, < 2.2.2
>= 2.3.0, < 2.3.2
1.15.5
2.0.4
2.1.3
2.2.2
2.3.2
tensorflow-cpu
< 1.15.5
1.15.5
tensorflow-cpu
>= 2.0.0, < 2.0.4
2.0.4
tensorflow-cpu
>= 2.1.0, < 2.1.3
2.1.3
tensorflow-cpu
>= 2.2.0, < 2.2.2
2.2.2
tensorflow-cpu
>= 2.3.0, < 2.3.2
2.3.2
tensorflow-cpu
< 1.15.5
>= 2.0.0, < 2.0.4
>= 2.1.0, < 2.1.3
>= 2.2.0, < 2.2.2
>= 2.3.0, < 2.3.2
1.15.5
2.0.4
2.1.3
2.2.2
2.3.2
tensorflow-gpu
< 1.15.5
1.15.5
tensorflow-gpu
>= 2.0.0, < 2.0.4
2.0.4
tensorflow-gpu
>= 2.1.0, < 2.1.3
2.1.3
tensorflow-gpu
>= 2.2.0, < 2.2.2
2.2.2
tensorflow-gpu
>= 2.3.0, < 2.3.2
2.3.2
tensorflow-gpu
< 1.15.5
>= 2.0.0, < 2.0.4
>= 2.1.0, < 2.1.3
>= 2.2.0, < 2.2.2
>= 2.3.0, < 2.3.2
1.15.5
2.0.4
2.1.3
2.2.2
2.3.2

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 1.15.5

pip
pip install --upgrade "tensorflow>=1.15.5"
poetry
poetry add "tensorflow>=1.15.5"
uv
uv add "tensorflow>=1.15.5"

tensorflow-cpu PyPI → 1.15.5

pip
pip install --upgrade "tensorflow-cpu>=1.15.5"
poetry
poetry add "tensorflow-cpu>=1.15.5"
uv
uv add "tensorflow-cpu>=1.15.5"

tensorflow-gpu PyPI → 1.15.5

pip
pip install --upgrade "tensorflow-gpu>=1.15.5"
poetry
poetry add "tensorflow-gpu>=1.15.5"
uv
uv add "tensorflow-gpu>=1.15.5"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

Attack vector
Local
Attack complexity
Low
Attack requirements
None
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
None
Integrity (vulnerable system)
Low
Availability (vulnerable system)
Low
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 4.4

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L

Attack vector
Local
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
Low
Availability
Low

Weakness

CWE-125: Out-of-bounds Read

The product reads data past the end, or before the beginning, of the intended buffer.

How to prevent it
  • Implementation: Assume all input is malicious. Use an "accept known good" input validation strategy, i.e., use a list of acceptable inputs that strictly conform to specifications. Reject any input that does not strictly conform to specifications, or transform it into something that does. When performing input validation, consider all potentially relevant properties, including length, type of input, the full range of acceptable values, missing or extra inputs, syntax, consistency across related fields, and conformance to business rules. As an example of business rule logic, "boat" may be syntactically valid because it only contains alphanumeric characters, but it is not valid if the input is only expected to contain colors such as "red" or "blue." Do not rely exclusively on looking for malicious or malformed inputs. This is likely to miss at least one undesirable input, especially if the code's environment changes. This can give attackers enough room to bypass the intended validation. However, denylists can be useful for detecting potential attacks or determining which inputs are so malformed that they should be rejected outright. To reduce the likelihood of introducing an out-of-bounds read, ensure that you validate and ensure correct calculations for any length argument, buffer size calculation, or offset. Be especially careful of relying on a sentinel (i.e. special character such as NUL) in untrusted inputs.
  • Architecture and Design: Use a language that provides appropriate memory abstractions.

CWE-908: Use of Uninitialized Resource

The product uses or accesses a resource that has not been initialized.

How to prevent it
  • Implementation: Explicitly initialize the resource before use. If this is performed through an API function or standard procedure, follow all required steps.
  • Implementation: Pay close attention to complex conditionals that affect initialization, since some branches might not perform the initialization.
  • Implementation: Avoid race conditions (CWE-362) during initialization routines.
  • Build and Compilation: Run or compile the product with settings that generate warnings about uninitialized variables or data.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor