Skip to content

GHSA-pqjj-6f5q-gqph CVE-2017-12602 PYSEC-2026-2827 PYSEC-2026-713

Denial of Service in OpenCV

High PyPI
Severity
7.5 / 10
High · CVSS 3.0
Exploit chance (EPSS)
2.99%
Chance of exploitation in the next 30 days. Higher than 87.34% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
—
Not classified
Fix
Available
2 packages have a fixed version

Description

OpenCV (Open Source Computer Vision Library) through 3.3 (corresponding to OpenCV-Python 3.3.0.9) has a denial of service (memory consumption) issue, as demonstrated by the 10-opencv-dos-memory-exhaust test case.

Affected versions

PyPI

PackageVulnerableFixed in
opencv-contrib-python
< 3.3.1.11
3.3.1.11
opencv-python
< 3.3.1.11
3.3.1.11

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

opencv-contrib-python PyPI → 3.3.1.11

pip
pip install --upgrade "opencv-contrib-python>=3.3.1.11"
poetry
poetry add "opencv-contrib-python>=3.3.1.11"
uv
uv add "opencv-contrib-python>=3.3.1.11"

opencv-python PyPI → 3.3.1.11

pip
pip install --upgrade "opencv-python>=3.3.1.11"
poetry
poetry add "opencv-python>=3.3.1.11"
uv
uv add "opencv-python>=3.3.1.11"

Severity breakdown

CVSS 3.0 7.5

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
High

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
PYSEC-2023-183
opencv-python versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863.
High Known exploited Also affects opencv-python
PYSEC-2023-181
opencv-contrib-python versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863.
High Known exploited Also affects opencv-contrib-python
GHSA-qr4w-53vh-m672
opencv-python bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863
High Also affects opencv-python
GHSA-cxjf-x6jp-p7mc
opencv-contrib-python bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863
High Also affects opencv-contrib-python
GHSA-9g8h-pjm4-q92p
Out-of-bounds Write in OpenCV.
Medium Also affects opencv-contrib-python
GHSA-q799-q27x-vp7w
Out-of-bounds Write in OpenCV
High Also affects opencv-contrib-python
GHSA-m6vm-8g8v-xfjh
Out-of-bounds Write in OpenCV
High Also affects opencv-contrib-python
GHSA-jggw-2q6g-c3m6
Out-of-bounds Read in OpenCV
Medium Also affects opencv-contrib-python
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor