GHSA-p8q6-qrgj-7gx2 CVE-2023-48122
Microweber allows a remote attacker to obtain sensitive information via the HTTP GET method
- Severity
- 7.5 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 0.85%
- Chance of exploitation in the next 30 days. Higher than 58.05% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
2.0.4- Upgrade microweber/microweber to this version or later
Description
An issue present in microweber v.2.0.1 and fixed in v.2.0.4 allows a remote attacker to obtain sensitive information via the HTTP GET method.
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| microweber/microweber | >= 2.0.1, < 2.0.4 |
2.0.4 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
microweber/microweber Packagist → 2.0.4
- composer
composer require microweber/microweber:^2.0.4
Severity breakdown
CVSS 3.1 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-vv4x-qcpq-wgrg Microweber vulnerable to Path Traversal | High | Also affects microweber/microweber |
| GHSA-6w5w-jx4x-vjvw Microweber Cross-site Scripting vulnerability | Medium | Also affects microweber/microweber |
| GHSA-5jg5-xqfw-rv92 Microweber has a Cross-site Scripting vulnerability | Medium | Also affects microweber/microweber |
| GHSA-2x2j-3c2v-g3c2 Microweber XSS Vulnerability in the homepage Endpoint | High | Also affects microweber/microweber |
| GHSA-mvj3-hc7j-vp74 Microweber has Reflected XSS Vulnerability in the layout Parameter | Medium | Also affects microweber/microweber |
| GHSA-8357-fjvx-xrm8 Microweber has Reflected XSS Vulnerability in the id Parameter | Medium | Also affects microweber/microweber |
| GHSA-782f-gxj5-xvqc Microweber Has Stored XSS Vulnerability in User Profile Fields | High | Also affects microweber/microweber |
| GHSA-j64v-xh5w-8hqj Microweber CMS API has authenticated local file inclusion vulnerability | High | Also affects microweber/microweber |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor