GHSA-p523-jrph-qjc6 CVE-2022-21652
Insufficient Session Expiration in shopware
- Severity
- 3.5 / 10
- Low · CVSS 3.1
- Exploit chance (EPSS)
- 0.82%
- Chance of exploitation in the next 30 days. Higher than 57.18% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-613 Insufficient Session Expiration
- Fix
5.7.7- Upgrade shopware/shopware to this version or later
Description
Impact
Automatically invalidate sessions upon password change
Patches
We recommend updating to the current version 5.7.7. You can get the update to 5.7.7 regularly via the Auto-Updater or directly via the download overview.
For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
References
https://docs.shopware.com/en/shopware-5-en/securityupdates/security-update-01-2022
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| shopware/shopware | >= 5.7.3, < 5.7.7 |
5.7.7 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
shopware/shopware Packagist → 5.7.7
- composer
composer require shopware/shopware:^5.7.7
Severity breakdown
CVSS 3.1 3.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Weakness
CWE-613: Insufficient Session Expiration
According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization."
How to prevent it
- Implementation: Set sessions/credentials expiration date.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-7cw6-7h3h-v8pf Shopware Has Improper Control of Generation of Code in Twig rendered views | High | Also affects shopware/shopware |
| GHSA-6w82-v552-wjw2 Shopware Storefront Reflected XSS in Storefront Login Page | Medium | Also affects shopware/shopware |
| GHSA-9v82-vcjx-m76j Shopware: Reflective Cross Site-Scripting (XSS) in CMS components | High | Also affects shopware/shopware |
| GHSA-83jv-4prm-34g7 Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-7336-ghhp-f2qj Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-jqr7-5h7r-ch8p Shopware Non-Persistent XSS in the Frontend | Medium | Also affects shopware/shopware |
| GHSA-q3g4-2vw9-xv27 Shopware Remote Code Execution Vulnerability | Critical | Also affects shopware/shopware |
| GHSA-gh66-fp7j-98v5 Shopware improper mail validation vulnerability | Medium | Also affects shopware/shopware |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor