GHSA-mgj2-q8wp-29rr BIT-typo3-2022-23502 CVE-2022-23502
TYPO3 CMS vulnerable to Insufficient Session Expiration after Password Reset
- Severity
- 5.4 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.43%
- Chance of exploitation in the next 30 days. Higher than 36.98% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-613 Insufficient Session Expiration
- Fix
- Available
- 2 packages have a fixed version
Description
Problem
When users reset their password using the corresponding password recovery functionality, existing sessions for that particular user account were not revoked. This applied to both frontend user sessions and backend user sessions.
Solution
Update to TYPO3 versions 10.4.33, 11.5.20, 12.1.1 that fix the problem described above.
References
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| typo3/cms | >= 10.0.0, < 10.4.33 |
10.4.33 |
| typo3/cms | >= 11.0.0, < 11.5.20 |
11.5.20 |
| typo3/cms | >= 12.0.0, < 12.1.1 |
12.1.1 |
| typo3/cms-core | >= 10.0.0, < 10.4.33 |
10.4.33 |
| typo3/cms-core | >= 11.0.0, < 11.5.20 |
11.5.20 |
| typo3/cms-core | >= 12.0.0, < 12.1.1 |
12.1.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
typo3/cms Packagist → 10.4.33
- composer
composer require typo3/cms:^10.4.33
typo3/cms-core Packagist → 10.4.33
- composer
composer require typo3/cms-core:^10.4.33
Severity breakdown
CVSS 3.1 5.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Weakness
CWE-613: Insufficient Session Expiration
According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization."
How to prevent it
- Implementation: Set sessions/credentials expiration date.
References
Advisories
Packages
Other links
- github.com/TYPO3/typo3/security/advisories/GHSA-mgj2-q8wp-29rr
- github.com/TYPO3/typo3/commit/d9ffbf24fcc62068033ebb3912538347bd380a6c
- github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms-core/CVE-2022…
- github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/CVE-2022-2350…
- typo3.org/security/advisory/typo3-core-sa-2022-014
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-68jx-f42c-7599 TYPO3 CMS - Broken Access Control in Backend and Install Tool | High | Also affects typo3/cms-core |
| GHSA-chm7-4vch-h8vr TYPO3 CMS has Broken Access Control in its Media Module | High | Also affects typo3/cms-core |
| GHSA-jh32-v29g-68pq TYPO3 CMS has Privilege Escalation & SQL Injection in its Form Framework | High | Also affects typo3/cms-core |
| GHSA-c78m-c52x-jgwp TYPO3 CMS has Insecure Deserialization via Core API | Medium | Also affects typo3/cms-core |
| GHSA-jf56-v8jc-jcc5 TYPO3 CMS has Broken Access Control in its File Abstraction Layer | Low | Also affects typo3/cms-core |
| GHSA-2j54-93q2-3hjq TYPO3 CMS has Broken Access Control in Backend API | Medium | Also affects typo3/cms-core |
| GHSA-q93m-25xv-94hh TYPO3 CMS: Broken Access Control in Media Module | Medium | Also affects typo3/cms-core |
| GHSA-qcmw-6rm2-5x78 TYPO3 CMS has Broken Access Control in its DataHandler | Medium | Also affects typo3/cms-core |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor