GHSA-m9fv-whq2-6wmc
Drupal core Multiple vulnerabilities due to the use of the third-party library Archive_Tar
- Severity
- 8.1 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- —
- No score published
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- —
- Not classified
- Fix
7.69- Upgrade drupal/drupal to this version or later
Description
The Drupal project uses the third-party library Archive_Tar, which has released a security improvement that is needed to protect some Drupal configurations.
Multiple vulnerabilities are possible if Drupal is configured to allow .tar, .tar.gz, .bz2 or .tlz file uploads and processes them.
The latest versions of Drupal update Archive_Tar to 1.4.9 to mitigate the file processing vulnerabilities.
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| drupal/drupal | >= 7.0.0, < 7.69 |
7.69 |
| drupal/drupal | >= 8.0.0, < 8.7.11 |
8.7.11 |
| drupal/drupal | >= 8.8.0, < 8.8.1 |
8.8.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
drupal/drupal Packagist → 7.69
- composer
composer require drupal/drupal:^7.69
Severity breakdown
CVSS 3.1 8.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- None
References
Packages
Other links
Timeline
- Published
- Last updated by the source
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| CVE-2020-13671 Drupal core Unrestricted Upload of File with Dangerous Type | High Known exploited | Also affects drupal/drupal |
| CVE-2019-6340 Drupal Core Remote Code Execution Vulnerability | High Known exploited | Also affects drupal/drupal |
| CVE-2018-7602 Drupal Core Remote Code Execution Vulnerability | Critical Known exploited | Also affects drupal/drupal |
| CVE-2018-7600 Drupal Core Remote Code Execution Vulnerability | Critical Known exploited | Also affects drupal/drupal |
| DRUPAL-CORE-2024-008 Drupal core contains a potential PHP Object Injection vulnerability | Critical | Also affects drupal/drupal |
| DRUPAL-CORE-2024-007 Drupal core contains a potential PHP Object Injection vulnerability | Critical | Also affects drupal/drupal |
| DRUPAL-CORE-2024-006 Drupal core contains a potential PHP Object Injection vulnerability | Critical | Also affects drupal/drupal |
| DRUPAL-CORE-2024-004 Drupal core Access bypass | High | Also affects drupal/drupal |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor