Skip to content

GHSA-m34j-p8rj-wjxq BIT-tensorflow-2021-29546 CVE-2021-29546 PYSEC-2021-183 PYSEC-2021-474 PYSEC-2021-672

Division by 0 in `QuantizedBiasAdd`

Low PyPI
Severity
0.0 / 10
Low · CVSS 4.0
Exploit chance (EPSS)
0.20%
Chance of exploitation in the next 30 days. Higher than 10.01% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-369 Divide By Zero
Fix
Available
3 packages have a fixed version

Description

Impact

An attacker can trigger an integer division by zero undefined behavior in tf.raw_ops.QuantizedBiasAdd:

import tensorflow as tf

input_tensor = tf.constant([], shape=[0, 0, 0, 0], dtype=tf.quint8)
bias = tf.constant([], shape=[0], dtype=tf.quint8)
min_input = tf.constant(-10.0, dtype=tf.float32)
max_input = tf.constant(-10.0, dtype=tf.float32)
min_bias = tf.constant(-10.0, dtype=tf.float32)
max_bias = tf.constant(-10.0, dtype=tf.float32)

tf.raw_ops.QuantizedBiasAdd(input=input_tensor, bias=bias, min_input=min_input,
                            max_input=max_input, min_bias=min_bias,
                            max_bias=max_bias, out_type=tf.qint32)

This is because the implementation of the Eigen kernel does a division by the number of elements of the smaller input (based on shape) without checking that this is not zero:

template <typename T1, typename T2, typename T3>
void QuantizedAddUsingEigen(const Eigen::ThreadPoolDevice& device,
                            const Tensor& input, float input_min,
                            float input_max, const Tensor& smaller_input,
                            float smaller_input_min, float smaller_input_max,
                            Tensor* output, float* output_min,
                            float* output_max) {
  ...
  const int64 input_element_count = input.NumElements();
  const int64 smaller_input_element_count = smaller_input.NumElements();
  ...
  bcast[0] = input_element_count / smaller_input_element_count;
  ...
}

This integral division by 0 is undefined behavior.

Patches

We have patched the issue in GitHub commit 67784700869470d65d5f2ef20aeb5e97c31673cb.

The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by Yakun Zhang and Ying Wang of Baidu X-Team.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
< 2.1.4
2.1.4
tensorflow
>= 2.2.0, < 2.2.3
2.2.3
tensorflow
>= 2.3.0, < 2.3.3
2.3.3
tensorflow
>= 2.4.0, < 2.4.2
2.4.2
tensorflow
< 2.2.0rc0
>= 2.2.0, < 2.3.0rc0
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.2.0rc0
2.3.0rc0
2.3.4
2.4.3
tensorflow-cpu
< 2.1.4
2.1.4
tensorflow-cpu
>= 2.2.0, < 2.2.3
2.2.3
tensorflow-cpu
>= 2.3.0, < 2.3.3
2.3.3
tensorflow-cpu
>= 2.4.0, < 2.4.2
2.4.2
tensorflow-cpu
< 2.2.0rc0
>= 2.2.0, < 2.3.0rc0
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.2.0rc0
2.3.0rc0
2.3.4
2.4.3
tensorflow-gpu
< 2.1.4
2.1.4
tensorflow-gpu
>= 2.2.0, < 2.2.3
2.2.3
tensorflow-gpu
>= 2.3.0, < 2.3.3
2.3.3
tensorflow-gpu
>= 2.4.0, < 2.4.2
2.4.2
tensorflow-gpu
< 2.2.0rc0
>= 2.2.0, < 2.3.0rc0
>= 2.3.0, < 2.3.4
>= 2.4.0, < 2.4.3
2.2.0rc0
2.3.0rc0
2.3.4
2.4.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.1.4

pip
pip install --upgrade "tensorflow>=2.1.4"
poetry
poetry add "tensorflow>=2.1.4"
uv
uv add "tensorflow>=2.1.4"

tensorflow-cpu PyPI → 2.1.4

pip
pip install --upgrade "tensorflow-cpu>=2.1.4"
poetry
poetry add "tensorflow-cpu>=2.1.4"
uv
uv add "tensorflow-cpu>=2.1.4"

tensorflow-gpu PyPI → 2.1.4

pip
pip install --upgrade "tensorflow-gpu>=2.1.4"
poetry
poetry add "tensorflow-gpu>=2.1.4"
uv
uv add "tensorflow-gpu>=2.1.4"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Attack vector
Local
Attack complexity
Low
Attack requirements
Present
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
None
Integrity (vulnerable system)
None
Availability (vulnerable system)
Low
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 2.5

CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L

Attack vector
Local
Attack complexity
High
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
Low

Weakness

CWE-369: Divide By Zero

The product divides a value by zero.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor