GHSA-jq6x-99hj-q636 BIT-tensorflow-2022-41884 CVE-2022-41884 PYSEC-2026-1013 PYSEC-2026-3208 PYSEC-2026-3345
Seg fault in `ndarray_tensor_bridge` due to zero and large inputs
- Severity
- 4.8 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.37%
- Chance of exploitation in the next 30 days. Higher than 30.98% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-670 Always-Incorrect Control Flow Implementation
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
If a numpy array is created with a shape such that one element is zero and the others sum to a large number, an error will be raised. E.g. the following raises an error:
np.ones((0, 2**31, 2**31))
An example of a proof of concept:
import numpy as np
import tensorflow as tf
input_val = tf.constant([1])
shape_val = np.array([i for i in range(21)])
tf.broadcast_to(input=input_val,shape=shape_val)
The return value of PyArray_SimpleNewFromData, which returns null on such shapes, is not checked.
Patches
We have patched the issue in GitHub commit 2b56169c16e375c521a3bc8ea658811cc0793784.
The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Pattarakrit Rattanukul.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.8.4 |
2.8.4 |
| tensorflow | >= 2.9.0, < 2.9.3 |
2.9.3 |
| tensorflow | >= 2.10.0, < 2.10.1 |
2.10.1 |
| tensorflow | < 2.8.4>= 2.9.0, < 2.9.3>= 2.10.0, < 2.10.1 |
2.8.42.9.32.10.1 |
| tensorflow-cpu | < 2.8.4 |
2.8.4 |
| tensorflow-cpu | >= 2.9.0, < 2.9.3 |
2.9.3 |
| tensorflow-cpu | >= 2.10.0, < 2.10.1 |
2.10.1 |
| tensorflow-cpu | < 2.8.4>= 2.9.0, < 2.9.3>= 2.10.0, < 2.10.1 |
2.8.42.9.32.10.1 |
| tensorflow-gpu | < 2.8.4 |
2.8.4 |
| tensorflow-gpu | >= 2.9.0, < 2.9.3 |
2.9.3 |
| tensorflow-gpu | >= 2.10.0, < 2.10.1 |
2.10.1 |
| tensorflow-gpu | < 2.8.4>= 2.9.0, < 2.9.3>= 2.10.0, < 2.10.1 |
2.8.42.9.32.10.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.8.4
- pip
pip install --upgrade "tensorflow>=2.8.4"- poetry
poetry add "tensorflow>=2.8.4"- uv
uv add "tensorflow>=2.8.4"
tensorflow-cpu PyPI → 2.8.4
- pip
pip install --upgrade "tensorflow-cpu>=2.8.4"- poetry
poetry add "tensorflow-cpu>=2.8.4"- uv
uv add "tensorflow-cpu>=2.8.4"
tensorflow-gpu PyPI → 2.8.4
- pip
pip install --upgrade "tensorflow-gpu>=2.8.4"- poetry
poetry add "tensorflow-gpu>=2.8.4"- uv
uv add "tensorflow-gpu>=2.8.4"
Severity breakdown
CVSS 3.1 4.8
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-670: Always-Incorrect Control Flow Implementation
The code contains a control flow path that does not reflect the algorithm that the path is intended to implement, leading to incorrect behavior any time this path is navigated.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor