GHSA-jfq2-rj7f-9gvf CVE-2018-7576 PYSEC-2019-206 PYSEC-2019-224 PYSEC-2019-231
Null pointer dereference in TensorFlow leads to exploitation
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 0.46%
- Chance of exploitation in the next 30 days. Higher than 39.63% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-476 NULL Pointer Dereference
- Fix
- Available
- 3 packages have a fixed version
Description
Google TensorFlow 1.0.0 through 1.5.1 is affected by: Null Pointer Dereference. The type of exploitation is: context-dependent.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | >= 1.0.0, < 1.6.0 |
1.6.0 |
| tensorflow | < 1.7.0rc0 |
1.7.0rc0 |
| tensorflow-cpu | < 1.7.0rc0 |
1.7.0rc0 |
| tensorflow-gpu | >= 1.0.0, < 1.6.0 |
1.6.0 |
| tensorflow-gpu | < 1.7.0rc0 |
1.7.0rc0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 1.6.0
- pip
pip install --upgrade "tensorflow>=1.6.0"- poetry
poetry add "tensorflow>=1.6.0"- uv
uv add "tensorflow>=1.6.0"
tensorflow-cpu PyPI → 1.7.0rc0
- pip
pip install --upgrade "tensorflow-cpu>=1.7.0rc0"- poetry
poetry add "tensorflow-cpu>=1.7.0rc0"- uv
uv add "tensorflow-cpu>=1.7.0rc0"
tensorflow-gpu PyPI → 1.6.0
- pip
pip install --upgrade "tensorflow-gpu>=1.6.0"- poetry
poetry add "tensorflow-gpu>=1.6.0"- uv
uv add "tensorflow-gpu>=1.6.0"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- None
- User interaction
- Passive
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.0 6.5
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-476: NULL Pointer Dereference
The product dereferences a pointer that it expects to be valid but is NULL.
How to prevent it
- Implementation: For any pointers that could have been modified or provided from a function that can return NULL, check the pointer for NULL before use. When working with a multithreaded or otherwise asynchronous environment, ensure that proper locking APIs are used to lock before the check, and unlock when it has finished [REF-1484].
- Requirements: Select a programming language that is not susceptible to these issues.
- Implementation: Check the results of all functions that return a value and verify that the value is non-null before acting upon it.
- Architecture and Design: Identify all variables and data stores that receive information from external sources, and apply input validation to make sure that they are only initialized to expected values.
- Implementation: Explicitly initialize all variables and other data stores, either during declaration or just before the first usage.
References
Advisories
Packages
Other links
- github.com/tensorflow/tensorflow/commit/c48431588e7cf8aff61d4c299231e3e925144df8
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-224…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-231…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-206.yaml
- github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-…
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor