Skip to content

GHSA-j86v-p27c-73fm BIT-tensorflow-2021-41201 CVE-2021-41201 PYSEC-2021-394 PYSEC-2021-611 PYSEC-2021-809

Unitialized access in `EinsumHelper::ParseEquation`

High PyPI
Severity
0.0 / 10
High · CVSS 4.0
Exploit chance (EPSS)
0.25%
Chance of exploitation in the next 30 days. Higher than 16.24% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-824 Access of Uninitialized Pointer
Fix
Available
3 packages have a fixed version

Description

Impact

During execution, EinsumHelper::ParseEquation() is supposed to set the flags in input_has_ellipsis vector and *output_has_ellipsis boolean to indicate whether there is ellipsis in the corresponding inputs and output.

However, the code only changes these flags to true and never assigns false.

for (int i = 0; i < num_inputs; ++i) {
  input_label_counts->at(i).resize(num_labels);
  for (const int label : input_labels->at(i)) {
    if (label != kEllipsisLabel)
      input_label_counts->at(i)[label] += 1;
    else
      input_has_ellipsis->at(i) = true;
  }
}
output_label_counts->resize(num_labels);
for (const int label : *output_labels) {
  if (label != kEllipsisLabel)
    output_label_counts->at(label) += 1;
  else
    *output_has_ellipsis = true;
}

This results in unitialized variable access if callers assume that EinsumHelper::ParseEquation() always sets these flags.

Patches

We have patched the issue in GitHub commit f09caa532b6e1ac8d2aa61b7832c78c5b79300c6.

The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
>= 2.6.0, < 2.6.1
2.6.1
tensorflow
>= 2.5.0, < 2.5.2
2.5.2
tensorflow
< 2.4.4
2.4.4
tensorflow
< 2.4.4
>= 2.5.0, < 2.5.2
>= 2.6.0, < 2.6.1
>= 2.7.0rc0, < 2.7.0
2.4.4
2.5.2
2.6.1
2.7.0
tensorflow-cpu
>= 2.6.0, < 2.6.1
2.6.1
tensorflow-cpu
>= 2.5.0, < 2.5.2
2.5.2
tensorflow-cpu
< 2.4.4
2.4.4
tensorflow-cpu
< 2.4.4
>= 2.5.0, < 2.5.2
>= 2.6.0, < 2.6.1
>= 2.7.0rc0, < 2.7.0
2.4.4
2.5.2
2.6.1
2.7.0
tensorflow-gpu
>= 2.6.0, < 2.6.1
2.6.1
tensorflow-gpu
>= 2.5.0, < 2.5.2
2.5.2
tensorflow-gpu
< 2.4.4
2.4.4
tensorflow-gpu
< 2.4.4
>= 2.5.0, < 2.5.2
>= 2.6.0, < 2.6.1
>= 2.7.0rc0, < 2.7.0
2.4.4
2.5.2
2.6.1
2.7.0

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.6.1

pip
pip install --upgrade "tensorflow>=2.6.1"
poetry
poetry add "tensorflow>=2.6.1"
uv
uv add "tensorflow>=2.6.1"

tensorflow-cpu PyPI → 2.6.1

pip
pip install --upgrade "tensorflow-cpu>=2.6.1"
poetry
poetry add "tensorflow-cpu>=2.6.1"
uv
uv add "tensorflow-cpu>=2.6.1"

tensorflow-gpu PyPI → 2.6.1

pip
pip install --upgrade "tensorflow-gpu>=2.6.1"
poetry
poetry add "tensorflow-gpu>=2.6.1"
uv
uv add "tensorflow-gpu>=2.6.1"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Attack vector
Local
Attack complexity
Low
Attack requirements
None
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
High
Integrity (vulnerable system)
High
Availability (vulnerable system)
High
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 7.8

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Attack vector
Local
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Weakness

CWE-824: Access of Uninitialized Pointer

The product accesses or uses a pointer that has not been initialized.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor