GHSA-j3mj-fhpq-qqjj BIT-tensorflow-2022-23571 CVE-2022-23571 PYSEC-2022-135 PYSEC-2022-80 PYSEC-2026-3204
Reachable Assertion in Tensorflow
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 0.47%
- Chance of exploitation in the next 30 days. Higher than 40.94% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-617 Reachable Assertion
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
When decoding a tensor from protobuf, a TensorFlow process can encounter cases where a CHECK assertion is invalidated based on user controlled arguments, if the tensors have an invalid dtype and 0 elements or an invalid shape. This allows attackers to cause denial of services in TensorFlow processes.
Patches
We have patched the issue in GitHub commit 5b491cd5e41ad63735161cec9c2a568172c8b6a3.
The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.5.3 |
2.5.3 |
| tensorflow | >= 2.6.0, < 2.6.3 |
2.6.3 |
| tensorflow | >= 2.7.0, < 2.7.1 |
2.7.1 |
| tensorflow | < 2.5.3>= 2.6.0, < 2.6.3>= 2.7.0, < 2.7.1 |
2.5.32.6.32.7.1 |
| tensorflow-cpu | < 2.5.3 |
2.5.3 |
| tensorflow-cpu | >= 2.6.0, < 2.6.3 |
2.6.3 |
| tensorflow-cpu | >= 2.7.0, < 2.7.1 |
2.7.1 |
| tensorflow-cpu | < 2.5.3>= 2.6.0, < 2.6.3 |
2.5.32.6.3 |
| tensorflow-gpu | < 2.5.3 |
2.5.3 |
| tensorflow-gpu | >= 2.6.0, < 2.6.3 |
2.6.3 |
| tensorflow-gpu | >= 2.7.0, < 2.7.1 |
2.7.1 |
| tensorflow-gpu | < 2.5.3>= 2.6.0, < 2.6.3 |
2.5.32.6.3 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.5.3
- pip
pip install --upgrade "tensorflow>=2.5.3"- poetry
poetry add "tensorflow>=2.5.3"- uv
uv add "tensorflow>=2.5.3"
tensorflow-cpu PyPI → 2.5.3
- pip
pip install --upgrade "tensorflow-cpu>=2.5.3"- poetry
poetry add "tensorflow-cpu>=2.5.3"- uv
uv add "tensorflow-cpu>=2.5.3"
tensorflow-gpu PyPI → 2.5.3
- pip
pip install --upgrade "tensorflow-gpu>=2.5.3"- poetry
poetry add "tensorflow-gpu>=2.5.3"- uv
uv add "tensorflow-gpu>=2.5.3"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-617: Reachable Assertion
The product contains an assert() or similar statement that can be triggered by an attacker, which leads to an application exit or other behavior that is more severe than necessary.
How to prevent it
- Implementation: Make sensitive open/close operation non reachable by directly user-controlled data (e.g. open/close resources)
- Implementation: Perform input validation on user data.
References
Advisories
Packages
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-j3mj-fhpq-qqjj
- github.com/tensorflow/tensorflow/commit/5b491cd5e41ad63735161cec9c2a568172c8b6a3
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-80.…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-135…
- github.com/tensorflow/tensorflow
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor