Skip to content

GHSA-hxfw-jm98-v4mq CVE-2019-15939 PYSEC-2026-2799 PYSEC-2026-2822 PYSEC-2026-2838 PYSEC-2026-722

Divide By Zero in OpenCV.

Medium PyPI
Severity
5.9 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
2.46%
Chance of exploitation in the next 30 days. Higher than 84.42% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-369 Divide By Zero
Fix
Available
4 packages have a fixed version

Description

An issue was discovered in OpenCV 4.1.0 (OpenCV-Python 4.1.0.25). There is a divide-by-zero error in cv::HOGDescriptor::getDescriptorSize in modules/objdetect/src/hog.cpp.

Affected versions

PyPI

PackageVulnerableFixed in
opencv-contrib-python
< 4.1.1.26
4.1.1.26
opencv-contrib-python-headless
< 4.1.1.26
4.1.1.26
opencv-contrib-python-headless
< 4.1.1.26
4.1.1.26
opencv-python
< 4.1.1.26
4.1.1.26
opencv-python
< 4.1.1.26
4.1.1.26
opencv-python-headless
< 4.1.1.26
4.1.1.26

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

opencv-contrib-python PyPI → 4.1.1.26

pip
pip install --upgrade "opencv-contrib-python>=4.1.1.26"
poetry
poetry add "opencv-contrib-python>=4.1.1.26"
uv
uv add "opencv-contrib-python>=4.1.1.26"

opencv-contrib-python-headless PyPI → 4.1.1.26

pip
pip install --upgrade "opencv-contrib-python-headless>=4.1.1.26"
poetry
poetry add "opencv-contrib-python-headless>=4.1.1.26"
uv
uv add "opencv-contrib-python-headless>=4.1.1.26"

opencv-python PyPI → 4.1.1.26

pip
pip install --upgrade "opencv-python>=4.1.1.26"
poetry
poetry add "opencv-python>=4.1.1.26"
uv
uv add "opencv-python>=4.1.1.26"

opencv-python-headless PyPI → 4.1.1.26

pip
pip install --upgrade "opencv-python-headless>=4.1.1.26"
poetry
poetry add "opencv-python-headless>=4.1.1.26"
uv
uv add "opencv-python-headless>=4.1.1.26"

Severity breakdown

CVSS 3.1 5.9

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Attack vector
Network
Attack complexity
High
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
High

Weakness

CWE-369: Divide By Zero

The product divides a value by zero.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
PYSEC-2023-183
opencv-python versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863.
High Known exploited Also affects opencv-python
PYSEC-2023-181
opencv-contrib-python versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863.
High Known exploited Also affects opencv-contrib-python
GHSA-qr4w-53vh-m672
opencv-python bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863
High Also affects opencv-python
GHSA-cxjf-x6jp-p7mc
opencv-contrib-python bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863
High Also affects opencv-contrib-python
GHSA-9g8h-pjm4-q92p
Out-of-bounds Write in OpenCV.
Medium Also affects opencv-contrib-python
GHSA-q799-q27x-vp7w
Out-of-bounds Write in OpenCV
High Also affects opencv-contrib-python
GHSA-m6vm-8g8v-xfjh
Out-of-bounds Write in OpenCV
High Also affects opencv-contrib-python
GHSA-jggw-2q6g-c3m6
Out-of-bounds Read in OpenCV
Medium Also affects opencv-contrib-python
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor