GHSA-hv9c-qwqg-qj3v CVE-2018-15685
Electron webPreferences vulnerability can be used to perform remote code execution
- Severity
- 8.1 / 10
- High · CVSS 3.0
- Exploit chance (EPSS)
- 10.30%
- Chance of exploitation in the next 30 days. Higher than 95.70% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-1188 Initialization of a Resource with an Insecure Default
- Fix
1.7.16- Upgrade electron to this version or later
Description
GitHub Electron 1.7.15, 1.8.7, 2.0.7, and 3.0.0-beta.6, in certain scenarios involving IFRAME elements and "nativeWindowOpen: true" or "sandbox: true" options, is affected by a webPreferences vulnerability that can be leveraged to perform remote code execution.
More information to determine if you are impacted can be found on the electron blog.
Recommendation
Upgrade Electron to >=3.0.0-beta.7, >=2.0.8, >=1.8.8, or >=1.7.16.
Affected versions
npm
| Package | Vulnerable | Fixed in |
|---|---|---|
| electron | >= 1.7.0, < 1.7.16 |
1.7.16 |
| electron | >= 1.8.0, < 1.8.8 |
1.8.8 |
| electron | >= 2.0.0, < 2.0.8 |
2.0.8 |
| electron | >= 3.0.0-beta.1, < 3.0.0-beta.7 |
3.0.0-beta.7 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
electron npm → 1.7.16
- npm
npm install electron@1.7.16- yarn
yarn add electron@1.7.16- pnpm
pnpm add electron@1.7.16
Severity breakdown
CVSS 3.0 8.1
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-1188: Initialization of a Resource with an Insecure Default
The product initializes or sets a resource with a default that is intended to be changed by the product's installer, administrator, or maintainer, but the default is not secure.
References
Advisories
Packages
Other links
- github.com/electron/electron/commit/519a02d8d4d28e8a467acb40fb26172a80c9454f
- github.com/electron/electron/commit/80221e52d93a96ea704cb6748ead669c55cff504
- github.com/electron/electron/commit/bab968ca776be28791e4dddfd50c86bd5fae62fa
- github.com/electron/electron/commit/ef0a6d9a1c96efc4657c6dd3a6624eba969f095b
- electronjs.org/blog/web-preferences-fix
- contrastsecurity.com/security-influencers/cve-2018-15685
- exploit-db.com/exploits/45272
- npmjs.com/advisories/732
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-qqvq-6xgj-jw8g Electron affected by libvpx's heap buffer overflow in vp8 encoding | High Known exploited | Also affects electron |
| GHSA-j7hp-h8jx-5ppr libwebp: OOB write in BuildHuffmanTable | High Known exploited | Also affects electron |
| GHSA-995f-9x5r-2rcj Heap buffer overflow in GPU | Critical Known exploited | Also affects electron |
| GHSA-jr5w-w6x2-84p9 Electron: Mitigation for compromised eMudhra intermediate certificates | High | Also affects electron |
| GHSA-h3v5-h239-pg29 Electron: Off-screen rendering on macOS trusts GPU-supplied frame geometry | Low | Also affects electron |
| GHSA-3qxv-5xgr-q7w9 Electron: Frame subscription trusts GPU-supplied frame geometry | Low | Also affects electron |
| GHSA-997q-gvvc-jwmx Electron: openExternal permission requests can be attributed to the wrong origin | Medium | Also affects electron |
| GHSA-fw47-9c62-h3vw Electron: HID and USB permission checks can be attributed to the wrong origin | Medium | Also affects electron |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor