Skip to content

GHSA-hq5m-mqmx-fw6m CVE-2021-37627

Privilege escalation via form generator

High Packagist
Severity
8.0 / 10
High · CVSS 3.1
Exploit chance (EPSS)
1.02%
Chance of exploitation in the next 30 days. Higher than 63.50% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-269 Improper Privilege Management
Fix
Available
2 packages have a fixed version

Description

Impact

It is possible for untrusted users to gain administrator rights with the form generator.

Installations are only affected if there are untrusted back end users with access to the form generator.

Patches

Update to Contao 4.4.56, 4.9.18 or 4.11.7.

Workarounds

Disable the form generator or disable the login for untrusted back end users.

References

https://contao.org/en/security-advisories/privilege-escalation-with-the-form-generator

For more information

If you have any questions or comments about this advisory, open an issue in contao/contao.

Affected versions

Packagist

PackageVulnerableFixed in
contao/contao
>= 4.0.0, < 4.4.56
4.4.56
contao/contao
>= 4.5.0, < 4.9.18
4.9.18
contao/contao
>= 4.10.0, < 4.11.7
4.11.7
contao/core-bundle
>= 4.0.0, < 4.4.56
4.4.56
contao/core-bundle
>= 4.5.0, < 4.9.18
4.9.18
contao/core-bundle
>= 4.10.0, < 4.11.7
4.11.7

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

contao/contao Packagist → 4.4.56

composer
composer require contao/contao:^4.4.56

contao/core-bundle Packagist → 4.4.56

composer
composer require contao/core-bundle:^4.4.56

Severity breakdown

CVSS 3.1 8.0

CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H

Attack vector
Network
Attack complexity
High
Privileges required
High
User interaction
None
Scope
Changed
Confidentiality
High
Integrity
High
Availability
High

Weakness

CWE-269: Improper Privilege Management

The product does not properly assign, modify, track, or check privileges for an actor, creating an unintended sphere of control for that actor.

How to prevent it
  • Architecture and Design, Operation: Very carefully manage the setting, management, and handling of privileges. Explicitly manage trust zones in the software.
  • Architecture and Design: Follow the principle of least privilege when assigning access rights to entities in a software system.
  • Architecture and Design: Consider following the principle of separation of privilege. Require multiple conditions to be met before permitting access to a system resource.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-9ff2-p842-45wq
Contao: Cross-site request forgery in custom backend actions
Low Also affects contao/core-bundle
GHSA-q6wp-fr43-gm9v
Contao: Improper access control in the preview links module
Medium Also affects contao/core-bundle
GHSA-5974-gfqc-wrcm
Contao: Improper access control in the table access voter
Medium Also affects contao/core-bundle
GHSA-mrvp-7wmx-5m4h
Contao: Path traversal in the images controller
Medium Also affects contao/core-bundle
GHSA-mfxh-vp55-7gc6
Contao: The registration module re-sends activation mails
Medium Also affects contao/core-bundle
GHSA-x2rp-9qf7-2fmq
Contao: Protected page content is disclosed to anonymous visitors after contao.search.index_protected is disabled
Medium Also affects contao/core-bundle
GHSA-grm4-wm43-9jh5
Contao: Possible path traversal in job download URIs
Low Also affects contao/contao
GHSA-87mg-5grr-rhwh
Contao: Server-Side Request Forgery (SSRF) via Unvalidated RSS Feed URL in Feed Reader Module
Low Also affects contao/contao
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor