GHSA-hhvc-g5hv-48c6 BIT-tensorflow-2020-26268 CVE-2020-26268 PYSEC-2020-255 PYSEC-2020-299 PYSEC-2020-334
Write to immutable memory region in TensorFlow
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 0.21%
- Chance of exploitation in the next 30 days. Higher than 11.48% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-471 Modification of Assumed-Immutable Data (MAID)
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
The tf.raw_ops.ImmutableConst operation returns a constant tensor created from a memory mapped file which is assumed immutable. However, if the type of the tensor is not an integral type, the operation crashes the Python interpreter as it tries to write to the memory area:
>>> import tensorflow as tf
>>> with open('/tmp/test.txt','w') as f: f.write('a'*128)
>>> tf.raw_ops.ImmutableConst(dtype=tf.string,shape=2,
memory_region_name='/tmp/test.txt')
If the file is too small, TensorFlow properly returns an error as the memory area has fewer bytes than what is needed for the tensor it creates. However, as soon as there are enough bytes, the above snippet causes a segmentation fault.
This is because the alocator used to return the buffer data is not marked as returning an opaque handle since the needed virtual method is not overriden.
Patches
We have patched the issue in GitHub commit c1e1fc899ad5f8c725dcbb6470069890b5060bc7 and will release TensorFlow 2.4.0 containing the patch. TensorFlow nightly packages after this commit will also have the issue resolved.
Since this issue also impacts TF versions before 2.4, we will patch all releases between 1.15 and 2.3 inclusive.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by members of the Aivul Team from Qihoo 360.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 1.15.5 |
1.15.5 |
| tensorflow | >= 2.0.0, < 2.0.4 |
2.0.4 |
| tensorflow | >= 2.1.0, < 2.1.3 |
2.1.3 |
| tensorflow | >= 2.2.0, < 2.2.2 |
2.2.2 |
| tensorflow | >= 2.3.0, < 2.3.2 |
2.3.2 |
| tensorflow | < 1.15.5>= 2.0.0, < 2.0.4>= 2.1.0, < 2.1.3>= 2.2.0, < 2.2.2>= 2.3.0, < 2.3.2 |
1.15.52.0.42.1.32.2.22.3.2 |
| tensorflow-cpu | < 1.15.5 |
1.15.5 |
| tensorflow-cpu | >= 2.0.0, < 2.0.4 |
2.0.4 |
| tensorflow-cpu | >= 2.1.0, < 2.1.3 |
2.1.3 |
| tensorflow-cpu | >= 2.2.0, < 2.2.2 |
2.2.2 |
| tensorflow-cpu | >= 2.3.0, < 2.3.2 |
2.3.2 |
| tensorflow-cpu | < 1.15.5>= 2.0.0, < 2.0.4>= 2.1.0, < 2.1.3>= 2.2.0, < 2.2.2>= 2.3.0, < 2.3.2 |
1.15.52.0.42.1.32.2.22.3.2 |
| tensorflow-gpu | < 1.15.5 |
1.15.5 |
| tensorflow-gpu | >= 2.0.0, < 2.0.4 |
2.0.4 |
| tensorflow-gpu | >= 2.1.0, < 2.1.3 |
2.1.3 |
| tensorflow-gpu | >= 2.2.0, < 2.2.2 |
2.2.2 |
| tensorflow-gpu | >= 2.3.0, < 2.3.2 |
2.3.2 |
| tensorflow-gpu | < 1.15.5>= 2.0.0, < 2.0.4>= 2.1.0, < 2.1.3>= 2.2.0, < 2.2.2>= 2.3.0, < 2.3.2 |
1.15.52.0.42.1.32.2.22.3.2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 1.15.5
- pip
pip install --upgrade "tensorflow>=1.15.5"- poetry
poetry add "tensorflow>=1.15.5"- uv
uv add "tensorflow>=1.15.5"
tensorflow-cpu PyPI → 1.15.5
- pip
pip install --upgrade "tensorflow-cpu>=1.15.5"- poetry
poetry add "tensorflow-cpu>=1.15.5"- uv
uv add "tensorflow-cpu>=1.15.5"
tensorflow-gpu PyPI → 1.15.5
- pip
pip install --upgrade "tensorflow-gpu>=1.15.5"- poetry
poetry add "tensorflow-gpu>=1.15.5"- uv
uv add "tensorflow-gpu>=1.15.5"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N
- Attack vector
- Local
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- Low
- Availability (vulnerable system)
- Low
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 4.4
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- Low
- Availability
- Low
Weakness
CWE-471: Modification of Assumed-Immutable Data (MAID)
The product does not properly protect an assumed-immutable element from being modified by an attacker.
How to prevent it
- Architecture and Design, Operation, Implementation: When the data is stored or transmitted through untrusted sources that could modify the data, implement integrity checks to detect unauthorized modification, or store/transmit the data in a trusted location that is free from external influence.
References
Advisories
Packages
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-hhvc-g5hv-48c6
- github.com/tensorflow/tensorflow/commit/c1e1fc899ad5f8c725dcbb6470069890b5060bc7
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-299…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-334…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-255.yaml
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor