GHSA-hgrr-935x-pq79 BIT-tomcat-2025-61795 CVE-2025-61795
Apache Tomcat Vulnerable to Improper Resource Shutdown or Release
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 1.25%
- Chance of exploitation in the next 30 days. Higher than 69.38% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-404 Improper Resource Shutdown or Release
- Fix
- Available
- 3 packages have a fixed version
Description
If an error occurred (including exceeding limits) during the processing of a multipart upload, temporary copies of the uploaded parts written to disc were not cleaned up immediately but left for the garbage collection process to delete. Depending on JVM settings, application memory usage and application load, it was possible that space for the temporary copies of uploaded parts would be filled faster than GC cleared it, leading to a DoS.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.11, from 10.1.0-M1 through 10.1.46, from 9.0.0.M1 through 9.0.109.
The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.12 or later, 10.1.47 or later or 9.0.110 or later which fixes the issue.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | >= 11.0.0-M1, < 11.0.12 |
11.0.12 |
| org.apache.tomcat.embed:tomcat-embed-core | >= 10.1.0-M1, < 10.1.47 |
10.1.47 |
| org.apache.tomcat.embed:tomcat-embed-core | >= 9.0.0.M1, < 9.0.110 |
9.0.110 |
| org.apache.tomcat.embed:tomcat-embed-core | >= 8.5.0, <= 8.5.100 |
No fix yet |
| org.apache.tomcat:tomcat | >= 11.0.0-M1, < 11.0.12 |
11.0.12 |
| org.apache.tomcat:tomcat | >= 10.1.0-M1, < 10.1.47 |
10.1.47 |
| org.apache.tomcat:tomcat | >= 9.0.0.M1, < 9.0.110 |
9.0.110 |
| org.apache.tomcat:tomcat | >= 8.5.0, <= 8.5.100 |
No fix yet |
| org.apache.tomcat:tomcat-catalina | >= 11.0.0-M1, < 11.0.12 |
11.0.12 |
| org.apache.tomcat:tomcat-catalina | >= 10.1.0-M1, < 10.1.47 |
10.1.47 |
| org.apache.tomcat:tomcat-catalina | >= 9.0.0.M1, < 9.0.110 |
9.0.110 |
| org.apache.tomcat:tomcat-catalina | >= 8.5.0, <= 8.5.100 |
No fix yet |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.tomcat.embed:tomcat-embed-core Maven → 11.0.12
- maven
<dependency><groupId>org.apache.tomcat.embed</groupId><artifactId>tomcat-embed-core</artifactId><version>11.0.12</version></dependency>- gradle
implementation("org.apache.tomcat.embed:tomcat-embed-core:11.0.12")
org.apache.tomcat:tomcat Maven → 11.0.12
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat</artifactId><version>11.0.12</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat:11.0.12")
org.apache.tomcat:tomcat-catalina Maven → 11.0.12
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat-catalina</artifactId><version>11.0.12</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat-catalina:11.0.12")
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U
- Attack vector
- Network
- Attack complexity
- Low
- Attack requirements
- Present
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
- Exploit maturity
- Unreported
CVSS 3.1 5.3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-404: Improper Resource Shutdown or Release
The product does not release or incorrectly releases a resource before it is made available for re-use.
How to prevent it
- Requirements: Use a language that does not allow this weakness to occur or provides constructs that make this weakness easier to avoid. For example, languages such as Java, Ruby, and Lisp perform automatic garbage collection that releases memory for objects that have been deallocated.
- Implementation: It is good practice to be responsible for freeing all resources you allocate and to be consistent with how and where you free memory in a function. If you allocate memory that you intend to free upon completion of the function, you must be sure to free the memory at all exit points for that function including error conditions.
- Implementation: Memory should be allocated/freed using matching functions such as malloc/free, new/delete, and new[]/delete[].
- Implementation: When releasing a complex object or structure, ensure that you properly dispose of all of its member components, not just the object itself.
References
Advisories
Packages
Other links
- github.com/apache/tomcat/commit/1cdf5f730ede75a0759492f179ac21ca4ff68e06
- github.com/apache/tomcat/commit/af6e9181620304c0d818121c29c074e1330610d0
- github.com/apache/tomcat/commit/afa422bd7ca1eef0f507259c682fd876494d9c3b
- cert-portal.siemens.com/productcert/html/ssa-032379.html
- lists.apache.org/thread/wm9mx8brmx9g4zpywm06ryrtvd3160pp
- tomcat.apache.org/security-10.html
- tomcat.apache.org/security-11.html
- tomcat.apache.org/security-9.html
- openwall.com/lists/oss-security/2025/10/27/6
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-69r9-qgr7-g2wj Apache Tomcat Missing Encryption of Sensitive Data vulnerability | High Known exploited | Also affects org.apache.tomcat:tomcat |
| GHSA-83qj-6fr2-vhqg Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT | Critical Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-qppj-fm5r-hxr3 HTTP/2 Stream Cancellation Attack | Medium Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-xjgh-84hx-56c5 Unrestricted Upload of File with Dangerous Type Apache Tomcat | High Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-cw54-59pw-4g8c Apache Tomcat Improper Access Control vulnerability | Critical Known exploited | Also affects org.apache.tomcat:tomcat-catalina |
| CVE-2020-1938 Improper Privilege Management in Tomcat | Critical Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-pjfr-qf3p-3q25 When running Apache Tomcat on Windows with HTTP PUTs enabled it was possible to upload a JSP file to the server | High Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-h3x4-894j-xpx5 Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability | Critical | Also affects org.apache.tomcat.embed:tomcat-embed-core |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor