GHSA-h67m-xg8f-fxcf BIT-tensorflow-2021-41213 CVE-2021-41213 PYSEC-2021-405 PYSEC-2021-622 PYSEC-2021-820
Deadlock in mutually recursive `tf.function` objects
- Severity
- 5.5 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.24%
- Chance of exploitation in the next 30 days. Higher than 15.52% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
The code behind tf.function API can be made to deadlock when two tf.function decorated Python functions are mutually recursive:
import tensorflow as tf
@tf.function()
def fun1(num):
if num == 1:
return
print(num)
fun2(num-1)
@tf.function()
def fun2(num):
if num == 0:
return
print(num)
fun1(num-1)
fun1(9)
This occurs due to using a non-reentrant Lock Python object.
Loading any model which contains mutually recursive functions is vulnerable. An attacker can cause denial of service by causing users to load such models and calling a recursive tf.function, although this is not a frequent scenario.
Patches
We have patched the issue in GitHub commit afac8158d43691661ad083f6dd9e56f327c1dcb7.
The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by members of the Aivul Team from Qihoo 360.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow | < 2.4.4 |
2.4.4 |
| tensorflow | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
| tensorflow-cpu | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow-cpu | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow-cpu | < 2.4.4 |
2.4.4 |
| tensorflow-cpu | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
| tensorflow-gpu | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow-gpu | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow-gpu | < 2.4.4 |
2.4.4 |
| tensorflow-gpu | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.6.1
- pip
pip install --upgrade "tensorflow>=2.6.1"- poetry
poetry add "tensorflow>=2.6.1"- uv
uv add "tensorflow>=2.6.1"
tensorflow-cpu PyPI → 2.6.1
- pip
pip install --upgrade "tensorflow-cpu>=2.6.1"- poetry
poetry add "tensorflow-cpu>=2.6.1"- uv
uv add "tensorflow-cpu>=2.6.1"
tensorflow-gpu PyPI → 2.6.1
- pip
pip install --upgrade "tensorflow-gpu>=2.6.1"- poetry
poetry add "tensorflow-gpu>=2.6.1"- uv
uv add "tensorflow-gpu>=2.6.1"
Severity breakdown
CVSS 3.1 5.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-662: Improper Synchronization
The product utilizes multiple threads, processes, components, or systems to allow temporary access to a shared resource that can only be exclusive to one process at a time, but it does not properly synchronize these actions, which might cause simultaneous accesses of this resource by multiple threads or processes.
How to prevent it
- Implementation: Use industry standard APIs to synchronize your code.
CWE-667: Improper Locking
The product does not properly acquire or release a lock on a resource, leading to unexpected resource state changes and behaviors.
How to prevent it
- Implementation: Use industry standard APIs to implement locking mechanism.
References
Advisories
Packages
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-h67m-xg8f-fxcf
- github.com/tensorflow/tensorflow/commit/afac8158d43691661ad083f6dd9e56f327c1dcb7
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-622…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-820…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-405.yaml
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor