GHSA-gh8h-7j2j-qv4f BIT-tensorflow-2021-41200 CVE-2021-41200 PYSEC-2021-393 PYSEC-2021-610 PYSEC-2021-808
Incomplete validation in `tf.summary.create_file_writer`
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 0.24%
- Chance of exploitation in the next 30 days. Higher than 14.85% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-617 Reachable Assertion
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
If tf.summary.create_file_writer is called with non-scalar arguments code crashes due to a CHECK-fail.
import tensorflow as tf
import numpy as np
tf.summary.create_file_writer(logdir='', flush_millis=np.ones((1,2)))
Patches
We have patched the issue in GitHub commit 874bda09e6702cd50bac90b453b50bcc65b2769e (merging #51715).
The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported externally via a GitHub issue.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow | < 2.4.4 |
2.4.4 |
| tensorflow | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
| tensorflow-cpu | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow-cpu | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow-cpu | < 2.4.4 |
2.4.4 |
| tensorflow-cpu | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
| tensorflow-gpu | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow-gpu | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow-gpu | < 2.4.4 |
2.4.4 |
| tensorflow-gpu | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.6.1
- pip
pip install --upgrade "tensorflow>=2.6.1"- poetry
poetry add "tensorflow>=2.6.1"- uv
uv add "tensorflow>=2.6.1"
tensorflow-cpu PyPI → 2.6.1
- pip
pip install --upgrade "tensorflow-cpu>=2.6.1"- poetry
poetry add "tensorflow-cpu>=2.6.1"- uv
uv add "tensorflow-cpu>=2.6.1"
tensorflow-gpu PyPI → 2.6.1
- pip
pip install --upgrade "tensorflow-gpu>=2.6.1"- poetry
poetry add "tensorflow-gpu>=2.6.1"- uv
uv add "tensorflow-gpu>=2.6.1"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Local
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 5.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-617: Reachable Assertion
The product contains an assert() or similar statement that can be triggered by an attacker, which leads to an application exit or other behavior that is more severe than necessary.
How to prevent it
- Implementation: Make sensitive open/close operation non reachable by directly user-controlled data (e.g. open/close resources)
- Implementation: Perform input validation on user data.
References
Advisories
Packages
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-gh8h-7j2j-qv4f
- github.com/tensorflow/tensorflow/issues/46909
- github.com/tensorflow/tensorflow/commit/874bda09e6702cd50bac90b453b50bcc65b2769e
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-610…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-808…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-393.yaml
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor