GHSA-g8pj-r55q-5c2v BIT-tomcat-2023-42795 CVE-2023-42795
Apache Tomcat Incomplete Cleanup vulnerability
- Severity
- 5.3 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 2.51%
- Chance of exploitation in the next 30 days. Higher than 84.81% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-459 Incomplete Cleanup
- Fix
- Available
- 4 packages have a fixed version
Description
Incomplete Cleanup vulnerability in Apache Tomcat.
When recycling various internal objects in Apache Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.80 and from 8.5.0 through 8.5.93, an error could cause Tomcat to skip some parts of the recycling process leading to information leaking from the current request/response to the next. Older, EOL versions may also be affected.
Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fixes the issue.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | >= 10.1.0-M1, < 10.1.14 |
10.1.14 |
| org.apache.tomcat.embed:tomcat-embed-core | >= 9.0.0-M1, < 9.0.81 |
9.0.81 |
| org.apache.tomcat.embed:tomcat-embed-core | >= 8.5.0, < 8.5.94 |
8.5.94 |
| org.apache.tomcat.embed:tomcat-embed-core | >= 11.0.0-M1, < 11.0.0-M12 |
11.0.0-M12 |
| org.apache.tomcat:tomcat | >= 11.0.0-M1, < 11.0.0-M12 |
11.0.0-M12 |
| org.apache.tomcat:tomcat | >= 10.1.0-M1, < 10.1.14 |
10.1.14 |
| org.apache.tomcat:tomcat | >= 9.0.0-M1, < 9.0.81 |
9.0.81 |
| org.apache.tomcat:tomcat | >= 8.5.0, < 8.5.94 |
8.5.94 |
| org.apache.tomcat:tomcat-catalina | >= 11.0.0-M1, < 11.0.0-M12 |
11.0.0-M12 |
| org.apache.tomcat:tomcat-catalina | >= 10.1.0-M1, < 10.1.14 |
10.1.14 |
| org.apache.tomcat:tomcat-catalina | >= 9.0.0-M1, < 9.0.81 |
9.0.81 |
| org.apache.tomcat:tomcat-catalina | >= 8.5.0, < 8.5.94 |
8.5.94 |
| org.apache.tomcat:tomcat-util | >= 11.0.0-M1, < 11.0.0-M12 |
11.0.0-M12 |
| org.apache.tomcat:tomcat-util | >= 10.1.0-M1, < 10.1.14 |
10.1.14 |
| org.apache.tomcat:tomcat-util | >= 9.0.0-M1, < 9.0.81 |
9.0.81 |
| org.apache.tomcat:tomcat-util | >= 8.5.0, < 8.5.94 |
8.5.94 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.tomcat.embed:tomcat-embed-core Maven → 10.1.14
- maven
<dependency><groupId>org.apache.tomcat.embed</groupId><artifactId>tomcat-embed-core</artifactId><version>10.1.14</version></dependency>- gradle
implementation("org.apache.tomcat.embed:tomcat-embed-core:10.1.14")
org.apache.tomcat:tomcat Maven → 11.0.0-M12
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat</artifactId><version>11.0.0-M12</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat:11.0.0-M12")
org.apache.tomcat:tomcat-catalina Maven → 11.0.0-M12
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat-catalina</artifactId><version>11.0.0-M12</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat-catalina:11.0.0-M12")
org.apache.tomcat:tomcat-util Maven → 11.0.0-M12
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat-util</artifactId><version>11.0.0-M12</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat-util:11.0.0-M12")
Severity breakdown
CVSS 3.1 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Weakness
CWE-459: Incomplete Cleanup
The product does not properly "clean up" and remove temporary or supporting resources after they have been used.
How to prevent it
- Architecture and Design, Implementation: Temporary files and other supporting resources should be deleted/released immediately after they are no longer needed.
References
Advisories
Packages
Other links
- github.com/apache/tomcat/commit/30f8063d7a9b4c43ae4722f5e382a76af1d7a6bf
- github.com/apache/tomcat/commit/44d05d75d696ca10ce251e4e370511e38f20ae75
- github.com/apache/tomcat/commit/9375d67106f8df9eb9d7b360b2bef052fe67d3d4
- github.com/apache/tomcat/commit/d6db22e411307c97ddf78315c15d5889356eca38
- lists.apache.org/thread/065jfyo583490r9j2v73nhpyxdob56lw
- lists.debian.org/debian-lts-announce/2023/10/msg00020.html
- security.netapp.com/advisory/ntap-20231103-0007
- debian.org/security/2023/dsa-5521
- debian.org/security/2023/dsa-5522
- openwall.com/lists/oss-security/2023/10/10/9
- security.netapp.com/advisory/ntap-20231103-0007
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-69r9-qgr7-g2wj Apache Tomcat Missing Encryption of Sensitive Data vulnerability | High Known exploited | Also affects org.apache.tomcat:tomcat |
| GHSA-83qj-6fr2-vhqg Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT | Critical Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-qppj-fm5r-hxr3 HTTP/2 Stream Cancellation Attack | Medium Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-xjgh-84hx-56c5 Unrestricted Upload of File with Dangerous Type Apache Tomcat | High Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-cw54-59pw-4g8c Apache Tomcat Improper Access Control vulnerability | Critical Known exploited | Also affects org.apache.tomcat:tomcat-catalina |
| CVE-2020-1938 Improper Privilege Management in Tomcat | Critical Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-pjfr-qf3p-3q25 When running Apache Tomcat on Windows with HTTP PUTs enabled it was possible to upload a JSP file to the server | High Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-h3x4-894j-xpx5 Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability | Critical | Also affects org.apache.tomcat.embed:tomcat-embed-core |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor