GHSA-g468-qj8g-vcjc BIT-tensorflow-2022-36016 CVE-2022-36016 PYSEC-2026-3184 PYSEC-2026-3327 PYSEC-2026-996
TensorFlow vulnerable to `CHECK`-fail in `tensorflow::full_type::SubstituteFromAttrs`
- Severity
- Low
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 0.70%
- Chance of exploitation in the next 30 days. Higher than 53.23% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-617 Reachable Assertion
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
When tensorflow::full_type::SubstituteFromAttrs receives a FullTypeDef& t that is not exactly three args, it triggers a CHECK-fail instead of returning a status.
Status SubstituteForEach(AttrMap& attrs, FullTypeDef& t) {
DCHECK_EQ(t.args_size(), 3);
const auto& cont = t.args(0);
const auto& tmpl = t.args(1);
const auto& t_var = t.args(2);
Patches
We have patched the issue in GitHub commit 6104f0d4091c260ce9352f9155f7e9b725eab012. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.7.2 |
2.7.2 |
| tensorflow | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
| tensorflow-cpu | < 2.7.2 |
2.7.2 |
| tensorflow-cpu | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow-cpu | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow-cpu | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
| tensorflow-gpu | < 2.7.2 |
2.7.2 |
| tensorflow-gpu | >= 2.8.0, < 2.8.1 |
2.8.1 |
| tensorflow-gpu | >= 2.9.0, < 2.9.1 |
2.9.1 |
| tensorflow-gpu | < 2.7.2>= 2.8.0, < 2.8.1>= 2.9.0, < 2.9.1 |
2.7.22.8.12.9.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow>=2.7.2"- poetry
poetry add "tensorflow>=2.7.2"- uv
uv add "tensorflow>=2.7.2"
tensorflow-cpu PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow-cpu>=2.7.2"- poetry
poetry add "tensorflow-cpu>=2.7.2"- uv
uv add "tensorflow-cpu>=2.7.2"
tensorflow-gpu PyPI → 2.7.2
- pip
pip install --upgrade "tensorflow-gpu>=2.7.2"- poetry
poetry add "tensorflow-gpu>=2.7.2"- uv
uv add "tensorflow-gpu>=2.7.2"
Weakness
CWE-617: Reachable Assertion
The product contains an assert() or similar statement that can be triggered by an attacker, which leads to an application exit or other behavior that is more severe than necessary.
How to prevent it
- Implementation: Make sensitive open/close operation non reachable by directly user-controlled data (e.g. open/close resources)
- Implementation: Perform input validation on user data.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor