GHSA-g466-57gh-cqfw CVE-2008-7311
Spree uses a hardcoded hash value
- Severity
- Medium
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 1.23%
- Chance of exploitation in the next 30 days. Higher than 68.94% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- —
- Not classified
- Fix
0.4.0- Upgrade spree to this version or later
Description
The session cookie store implementation in Spree 0.2.0 uses a hardcoded config.action_controller_session hash value (aka secret key), which makes it easier for remote attackers to bypass cryptographic protection mechanisms by leveraging an application that contains this value within the config/environment.rb file.
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| spree | < 0.4.0 |
0.4.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
spree RubyGems → 0.4.0
- bundler
bundle update spree # Gemfile: gem "spree", ">= 0.4.0"
References
Advisories
Packages
Other links
- github.com/rubysec/ruby-advisory-db/blob/master/gems/spree/CVE-2008-7311.yml
- spreecommerce.com/blog/security-vulernability-session-cookie-store
- web.archive.org/web/20090306033106/http://support.spreehq.org/issues/show/63
- web.archive.org/web/20100309050152/http://rubygems.org/gems/spree/versions
- web.archive.org/web/20101128024939/http://spreecommerce.com/blog/2008/08/12/security…
- spreecommerce.com/blog/2008/08/12/security-vulernability-session-cookie-store
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-xf4v-w5x5-pv79 Spree: CSV Formula Injection in Customer Export | Medium | Also affects spree |
| GHSA-x485-rhg3-cqr4 Spree Commerce is vulnerable to RCE through Search API | Critical | Also affects spree |
| GHSA-97vm-c39p-jr86 Spree has Remote Command Execution vulnerability in search functionality | Critical | Also affects spree |
| GHSA-7h48-m3rw-vr27 Spree does not properly restrict the use of a hash to provide values for a model's attributes | Medium | Also affects spree |
| GHSA-hwrx-wc75-mgh7 Spree allows remote attackers to obtain sensitive information | Medium | Also affects spree |
| GHSA-f8cm-364f-q9qh Ensure that doorkeeper_token is valid when authenticating requests in API v2 calls | High | Also affects spree |
| GHSA-jxx8-v83v-rhw3 Spree Improper Input Validation vulnerability | Medium | Also affects spree |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor