GHSA-fxjg-28fm-pfxh BIT-superset-2023-25504 CVE-2023-25504 PYSEC-2026-1179
Apache Superset Server-Side Request Forgery vulnerability
- Severity
- 6.5 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.96%
- Chance of exploitation in the next 30 days. Higher than 61.46% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-918 Server-Side Request Forgery (SSRF)
- Fix
2.1.0- Upgrade apache-superset to this version or later
Description
A malicious actor who has been authenticated and granted specific permissions in Apache Superset may use the import dataset feature in order to conduct Server-Side Request Forgery attacks and query internal resources on behalf of the server where Superset is deployed. This vulnerability exists in Apache Superset versions up to and including 2.0.1.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| apache-superset | < 2.1.0 |
2.1.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
apache-superset PyPI → 2.1.0
- pip
pip install --upgrade "apache-superset>=2.1.0"- poetry
poetry add "apache-superset>=2.1.0"- uv
uv add "apache-superset>=2.1.0"
Severity breakdown
CVSS 3.1 6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Weakness
CWE-918: Server-Side Request Forgery (SSRF)
The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-5cx2-vq3h-x52c Apache superset missing check for default SECRET_KEY | Critical Known exploited | Also affects apache-superset |
| GHSA-mwf2-qr4v-94h2 Apache Superset: Read-Only Bypass via Improper Input Validation on PostgreSQL Connections | Medium | Also affects apache-superset |
| GHSA-h294-8fxm-m2pj Apache Superset allows authenticated users to view sensitive data without explicit permissions | Medium | Also affects apache-superset |
| GHSA-3m2g-v7jf-7fxc Apache Superset Improper Authorization allows low-privileged users to bypass access controls | Medium | Also affects apache-superset |
| GHSA-gvxg-9hqx-f4rg Apache Superset allows privileged users to conduct error-based SQL Injection | Medium | Also affects apache-superset |
| GHSA-48m2-v2r8-h23m Apache Superset: Incomplete DISALLOWED_SQL_FUNCTIONS default list for ClickHouse engine | Medium | Also affects apache-superset |
| GHSA-mhpq-m962-mg92 Apache Superset allows authenticated users to discover metadata about datasources they don't have permission to access | Medium | Also affects apache-superset |
| GHSA-fxgf-3xh6-m2pp Apache Superset has bypass of `DISALLOWED_SQL_FUNCTIONS` that allows execution of blocked SQL functions | Medium | Also affects apache-superset |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor