Skip to content

GHSA-fx49-4h83-wjv9 CVE-2026-105855

Payload didn't enforce field-level password update restrictions

High npm
Severity
0.0 / 10
High · CVSS 4.0
Exploit chance (EPSS)
0.25%
Chance of exploitation in the next 30 days. Higher than 16.16% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-284 Improper Access Control
Fix
3.90.0
Upgrade payload to this version or later

Description

Impact

When an auth collection defined a field-level access.update restriction on the password field, the restriction was not enforced on the server correctly.

Patches

Users should upgrade Payload packages to >= 3.90.0 or >= 4.0.0-canary.34.

Affected versions

npm

PackageVulnerableFixed in
payload
< 3.90.0
3.90.0
payload
>= 4.0.0-canary.0, < 4.0.0-canary.34
4.0.0-canary.34

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

payload npm → 3.90.0

npm
npm install payload@3.90.0
yarn
yarn add payload@3.90.0
pnpm
pnpm add payload@3.90.0

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
Present
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
High
Integrity (vulnerable system)
High
Availability (vulnerable system)
None
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 7.1

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
High
Availability
None

Weakness

CWE-284: Improper Access Control

The product does not restrict or incorrectly restricts access to a resource from an unauthorized actor.

How to prevent it
  • Architecture and Design, Operation: Very carefully manage the setting, management, and handling of privileges. Explicitly manage trust zones in the software.
  • Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-9qpg-3cf8-w33x
Payload: Uploaded XML files could execute same-origin JavaScript
High Also affects payload
GHSA-v5gf-vpjc-pc7w
Payload: Unauthenticated account-lockout denial of service
High Also affects payload
GHSA-p223-2wr2-j562
Payload: Incomplete validation during the upload file lifecycle
High Also affects payload
GHSA-66wr-7vmr-p5jq
Payload authentication token field handling issue
Critical Also affects payload
GHSA-2pwp-2369-8fg3
Payload: Bypassed sanitization of user uploaded SVGs
High Also affects payload
GHSA-pj5h-5q6c-3pfx
Payload external upload trust validation issue
High Also affects payload
GHSA-f7hx-52q9-hcrf
Payload: Unauthorized update to collection documents
Critical Also affects payload
GHSA-97rh-rhh2-7vjv
Payload: Remote Code Execution through first-register
High Also affects payload
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor