Skip to content

GHSA-fwfg-vprh-97ph CVE-2023-41047 PYSEC-2023-195

OctoPrint vulnerable to Improper Neutralization of Special Elements Used in a Template Engine

Medium PyPI
Severity
0.0 / 10
Medium · CVSS 4.0
Exploit chance (EPSS)
0.59%
Chance of exploitation in the next 30 days. Higher than 48.10% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-1336 Improper Neutralization of Special Elements Used in a Template Engine
Fix
1.9.3
Upgrade octoprint to this version or later

Description

Impact

OctoPrint versions up until and including 1.9.2 contain a vulnerability that allows malicious admins to configure a specially crafted GCODE script through the Settings that will allow code execution during rendering of that script.

An attacker might use this to extract data managed by OctoPrint, or manipulate data managed by OctoPrint, as well as execute arbitrary commands with the rights of the OctoPrint process on the server system.

Please note that GCODE files uploaded to be printed are not affected! This vulnerability exclusively affects GCODE Scripts to be executed on connection to the printer, print pause, resume etc, as described in the documentation, to be found under Settings > GCODE Scripts and configurable only by users with the ADMIN permission.

Patches

The vulnerability has been patched in version 1.9.3.

Workarounds

OctoPrint administrators are strongly advised to thoroughly vet who has admin access to their installation and to not blindly configure arbitrary GCODE scripts found online or provided to them by third parties.

Credits

This vulnerability was discovered and responsibly disclosed to OctoPrint by tianxin Wu (Bearcat), Vulnerability Researcher at Numen Cyber Labs, Singapore.

Affected versions

PyPI

PackageVulnerableFixed in
octoprint
< 1.9.3
1.9.3
octoprint
< 1.9.3
1.9.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

octoprint PyPI → 1.9.3

pip
pip install --upgrade "octoprint>=1.9.3"
poetry
poetry add "octoprint>=1.9.3"
uv
uv add "octoprint>=1.9.3"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
None
Privileges required
High
User interaction
Active
Confidentiality (vulnerable system)
High
Integrity (vulnerable system)
High
Availability (vulnerable system)
High
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 6.5

CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

Attack vector
Local
Attack complexity
Low
Privileges required
High
User interaction
Required
Scope
Unchanged
Confidentiality
High
Integrity
High
Availability
High

Weakness

CWE-1336: Improper Neutralization of Special Elements Used in a Template Engine

The product uses a template engine to insert or process externally-influenced input, but it does not neutralize or incorrectly neutralizes special elements or syntax that can be interpreted as template expressions or other code directives when processed by the engine.

How to prevent it
  • Architecture and Design: Choose a template engine that offers a sandbox or restricted mode, or at least limits the power of any available expressions, function calls, or commands.
  • Implementation: Use the template engine's sandbox or restricted mode, if available.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-j4h9-pm27-4rfw
OctoPrint has possible file exfiltration via query parameters on upload endpoints
High Also affects octoprint
GHSA-p6qx-ghxm-389h
OctoPrint has XSS in its Suppressed Command Notifications
Medium Also affects octoprint
GHSA-xg4x-w2j3-57h6
OctoPrint has Timing Side-Channel Vulnerability in API Key Authentication
Medium Also affects octoprint
GHSA-crvm-xjhm-9h29
OctoPrint vulnerable to XSS in Action Commands Notification and Prompt
Medium Also affects octoprint
GHSA-49mj-x8jp-qvfc
OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload
High Also affects octoprint
GHSA-9wj4-8h85-pgrw
OctoPrint Vulnerable to Denial of Service through malformed HTTP request in OctoPrint
Medium Also affects octoprint
GHSA-m9jh-jf9h-x3h2
OctoPrint vulnerable to possible file extraction via upload endpoints
Medium Also affects octoprint
GHSA-qw93-h6pf-226x
OctoPrint Authenticated Reverse Proxy Page Authentication Bypass
Medium Also affects octoprint
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor