Skip to content

GHSA-fv25-8xcx-gqjc BIT-tomcat-2026-42498 CVE-2026-42498

Apache Tomcat - WebSocket authentication header exposure

High Maven
Severity
7.3 / 10
High · CVSS 3.1
Exploit chance (EPSS)
0.65%
Chance of exploitation in the next 30 days. Higher than 50.96% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
Fix
Available
3 packages have a fixed version

Description

Versions Affected: Apache Tomcat 11.0.0-M1 to 11.0.21 Apache Tomcat 10.1.0-M1 to 10.1.54 Apache Tomcat 9.0.2 to 9.0.117 Older, unsupported versions may also be affected

Description: If a WebSocket request was redirected after authentication, Tomcat's WebSocket client would present the most recent authentication header to the redirect target host.

Mitigation: Users of the affected versions should apply one of the following mitigations:

  • Upgrade to Apache Tomcat 11.0.22 or later
  • Upgrade to Apache Tomcat 10.1.55 or later
  • Upgrade to Apache Tomcat 9.0.118 or later

Credit: This issue was identified by lokerxx

Affected versions

Maven

PackageVulnerableFixed in
org.apache.tomcat.embed:tomcat-embed-core
< 9.0.118
9.0.118
org.apache.tomcat.embed:tomcat-embed-core
>= 10.1.0-M1, < 10.1.55
10.1.55
org.apache.tomcat.embed:tomcat-embed-core
>= 11.0.0-M1, < 11.0.22
11.0.22
org.apache.tomcat:tomcat
< 9.0.118
9.0.118
org.apache.tomcat:tomcat
>= 10.1.0-M1, < 10.1.55
10.1.55
org.apache.tomcat:tomcat
>= 11.0.0-M1, < 11.0.22
11.0.22
org.apache.tomcat:tomcat-catalina
< 9.0.118
9.0.118
org.apache.tomcat:tomcat-catalina
>= 10.1.0-M1, < 10.1.55
10.1.55
org.apache.tomcat:tomcat-catalina
>= 11.0.0-M1, < 11.0.22
11.0.22

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

org.apache.tomcat.embed:tomcat-embed-core Maven → 9.0.118

maven
<dependency><groupId>org.apache.tomcat.embed</groupId><artifactId>tomcat-embed-core</artifactId><version>9.0.118</version></dependency>
gradle
implementation("org.apache.tomcat.embed:tomcat-embed-core:9.0.118")

org.apache.tomcat:tomcat Maven → 9.0.118

maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat</artifactId><version>9.0.118</version></dependency>
gradle
implementation("org.apache.tomcat:tomcat:9.0.118")

org.apache.tomcat:tomcat-catalina Maven → 9.0.118

maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat-catalina</artifactId><version>9.0.118</version></dependency>
gradle
implementation("org.apache.tomcat:tomcat-catalina:9.0.118")

Severity breakdown

CVSS 3.1 7.3

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
Low

Weakness

CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.

How to prevent it
  • Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-69r9-qgr7-g2wj
Apache Tomcat Missing Encryption of Sensitive Data vulnerability
High Known exploited Also affects org.apache.tomcat:tomcat
GHSA-83qj-6fr2-vhqg
Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT
Critical Known exploited Also affects org.apache.tomcat.embed:tomcat-embed-core
GHSA-qppj-fm5r-hxr3
HTTP/2 Stream Cancellation Attack
Medium Known exploited Also affects org.apache.tomcat.embed:tomcat-embed-core
GHSA-xjgh-84hx-56c5
Unrestricted Upload of File with Dangerous Type Apache Tomcat
High Known exploited Also affects org.apache.tomcat.embed:tomcat-embed-core
GHSA-cw54-59pw-4g8c
Apache Tomcat Improper Access Control vulnerability
Critical Known exploited Also affects org.apache.tomcat:tomcat-catalina
CVE-2020-1938
Improper Privilege Management in Tomcat
Critical Known exploited Also affects org.apache.tomcat.embed:tomcat-embed-core
GHSA-pjfr-qf3p-3q25
When running Apache Tomcat on Windows with HTTP PUTs enabled it was possible to upload a JSP file to the server
High Known exploited Also affects org.apache.tomcat.embed:tomcat-embed-core
GHSA-h3x4-894j-xpx5
Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability
Critical Also affects org.apache.tomcat.embed:tomcat-embed-core
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor