GHSA-frqp-wp83-qggv BIT-tensorflow-2022-41910 CVE-2022-41910 PYSEC-2026-3178 PYSEC-2026-3323 PYSEC-2026-992
Heap overflow in `QuantizeAndDequantizeV2`
- Severity
- 4.8 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 0.44%
- Chance of exploitation in the next 30 days. Higher than 38.14% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-125 Out-of-bounds Read
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
The function MakeGrapplerFunctionItem takes arguments that determine the sizes of inputs and outputs. If the inputs given are greater than or equal to the sizes of the outputs, an out-of-bounds memory read or a crash is triggered.
import tensorflow as tf
@tf.function
def test():
tf.raw_ops.QuantizeAndDequantizeV2(input=[2.5],
input_min=[1.0],
input_max=[10.0],
signed_input=True,
num_bits=1,
range_given=True,
round_mode='HALF_TO_EVEN',
narrow_range=True,
axis=0x7fffffff)
test()
Patches
We have patched the issue in GitHub commit 7b174a0f2e40ff3f3aa957aecddfd5aaae35eccb.
The fix will be included in TensorFlow 2.11.0. We will also cherrypick this commit on TensorFlow 2.10.1.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.8.4 |
2.8.4 |
| tensorflow | >= 2.9.0, < 2.9.3 |
2.9.3 |
| tensorflow | >= 2.10.0, < 2.10.1 |
2.10.1 |
| tensorflow | < 2.8.4>= 2.9.0, < 2.9.3>= 2.10.0, < 2.10.1 |
2.8.42.9.32.10.1 |
| tensorflow-cpu | < 2.8.4 |
2.8.4 |
| tensorflow-cpu | >= 2.9.0, < 2.9.3 |
2.9.3 |
| tensorflow-cpu | >= 2.10.0, < 2.10.1 |
2.10.1 |
| tensorflow-cpu | < 2.8.4>= 2.9.0, < 2.9.3>= 2.10.0, < 2.10.1 |
2.8.42.9.32.10.1 |
| tensorflow-gpu | < 2.8.4 |
2.8.4 |
| tensorflow-gpu | >= 2.9.0, < 2.9.3 |
2.9.3 |
| tensorflow-gpu | >= 2.10.0, < 2.10.1 |
2.10.1 |
| tensorflow-gpu | < 2.8.4>= 2.9.0, < 2.9.3>= 2.10.0, < 2.10.1 |
2.8.42.9.32.10.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.8.4
- pip
pip install --upgrade "tensorflow>=2.8.4"- poetry
poetry add "tensorflow>=2.8.4"- uv
uv add "tensorflow>=2.8.4"
tensorflow-cpu PyPI → 2.8.4
- pip
pip install --upgrade "tensorflow-cpu>=2.8.4"- poetry
poetry add "tensorflow-cpu>=2.8.4"- uv
uv add "tensorflow-cpu>=2.8.4"
tensorflow-gpu PyPI → 2.8.4
- pip
pip install --upgrade "tensorflow-gpu>=2.8.4"- poetry
poetry add "tensorflow-gpu>=2.8.4"- uv
uv add "tensorflow-gpu>=2.8.4"
Severity breakdown
CVSS 3.1 4.8
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H
- Attack vector
- Network
- Attack complexity
- High
- Privileges required
- Low
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-125: Out-of-bounds Read
The product reads data past the end, or before the beginning, of the intended buffer.
How to prevent it
- Implementation: Assume all input is malicious. Use an "accept known good" input validation strategy, i.e., use a list of acceptable inputs that strictly conform to specifications. Reject any input that does not strictly conform to specifications, or transform it into something that does. When performing input validation, consider all potentially relevant properties, including length, type of input, the full range of acceptable values, missing or extra inputs, syntax, consistency across related fields, and conformance to business rules. As an example of business rule logic, "boat" may be syntactically valid because it only contains alphanumeric characters, but it is not valid if the input is only expected to contain colors such as "red" or "blue." Do not rely exclusively on looking for malicious or malformed inputs. This is likely to miss at least one undesirable input, especially if the code's environment changes. This can give attackers enough room to bypass the intended validation. However, denylists can be useful for detecting potential attacks or determining which inputs are so malformed that they should be rejected outright. To reduce the likelihood of introducing an out-of-bounds read, ensure that you validate and ensure correct calculations for any length argument, buffer size calculation, or offset. Be especially careful of relying on a sentinel (i.e. special character such as NUL) in untrusted inputs.
- Architecture and Design: Use a language that provides appropriate memory abstractions.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor