Skip to content

GHSA-fr5h-rqp8-mj6g CVE-2024-34351

Next.js Server-Side Request Forgery in Server Actions

High npm
Severity
7.5 / 10
High · CVSS 3.1
Exploit chance (EPSS)
5.45%
Chance of exploitation in the next 30 days. Higher than 92.74% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-918 Server-Side Request Forgery (SSRF)
Fix
14.1.1
Upgrade next to this version or later

Description

Impact

A Server-Side Request Forgery (SSRF) vulnerability was identified in Next.js Server Actions by security researchers at Assetnote. If the Host header is modified, and the below conditions are also met, an attacker may be able to make requests that appear to be originating from the Next.js application server itself.

Prerequisites

  • Next.js (<14.1.1) is running in a self-hosted* manner.
  • The Next.js application makes use of Server Actions.
  • The Server Action performs a redirect to a relative path which starts with a /.

* Many hosting providers (including Vercel) route requests based on the Host header, so we do not believe that this vulnerability affects any Next.js applications where routing is done in this manner.

Patches

This vulnerability was patched in #62561 and fixed in Next.js 14.1.1.

Workarounds

There are no official workarounds for this vulnerability. We recommend upgrading to Next.js 14.1.1.

Credit

Vercel and the Next.js team thank Assetnote for responsibly disclosing this issue to us, and for working with us to verify the fix. Thanks to:

Adam Kues - Assetnote Shubham Shah - Assetnote

Affected versions

npm

PackageVulnerableFixed in
next
>= 13.4.0, < 14.1.1
14.1.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

next npm → 14.1.1

npm
npm install next@14.1.1
yarn
yarn add next@14.1.1
pnpm
pnpm add next@14.1.1

Severity breakdown

CVSS 3.1 7.5

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Attack vector
Network
Attack complexity
Low
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
High
Integrity
None
Availability
None

Weakness

CWE-918: Server-Side Request Forgery (SSRF)

The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-673q-mjm6-r5xr
Next.js: Unauthenticated Remote Code Execution in `use cache` functions returning typed arrays
Critical Also affects next
GHSA-2464-fhr4-w9xw
Next.js: Unauthenticated Remote Code Execution in Image Optimization API when SVG files are used
Critical Also affects next
GHSA-p3m5-59mp-jv5r
Next.js: Denial of Service in App Router using Server Actions
High Also affects next
GHSA-3w37-wq28-93x7
Next.js: Pending `use cache` fill can leak Draft Mode content into regular responses and persisted pages
Medium Also affects next
GHSA-4jqv-mc3x-m676
Next.js has cache poisoning of SSG and ISR pages in self-hosted applications
Medium Also affects next
GHSA-39w2-rjm5-chcv
Next.js has information disclosure in development server's Model Context Protocol endpoint
Medium Also affects next
GHSA-f87g-xv8r-7p7x
Next.js has information disclosure in App Router metadata image routes via dynamicParams bypass
Medium Also affects next
GHSA-mcj8-r9mp-w47p
Next.js has cache poisoning in SSG/ISR rendering that leads to cross-user content substitution and persistent denial of service
Medium Also affects next
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor