Skip to content

GHSA-fqxc-pvf8-2w9v BIT-tensorflow-2022-36000 CVE-2022-36000 PYSEC-2026-3177 PYSEC-2026-3322 PYSEC-2026-991

TensorFlow vulnerable to null dereference on MLIR on empty function attributes

Medium PyPI
Severity
5.9 / 10
Medium · CVSS 3.1
Exploit chance (EPSS)
0.48%
Chance of exploitation in the next 30 days. Higher than 41.25% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-476 NULL Pointer Dereference
Fix
Available
3 packages have a fixed version

Description

Impact

Eig can be fed an incorrect Tout input, resulting in a CHECK fail that can trigger a denial of service attack.

import tensorflow as tf
import numpy as np 
arg_0=tf.constant(value=np.random.random(size=(2, 2)), shape=(2, 2), dtype=tf.float32)
arg_1=tf.complex128
arg_2=True
arg_3=''
tf.raw_ops.Eig(input=arg_0, Tout=arg_1, compute_v=arg_2, name=arg_3)

Patches

We have patched the issue in GitHub commit aed36912609fc07229b4d0a7b44f3f48efc00fd0.

The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by 刘力源, Information System & Security and Countermeasures Experiments Center, Beijing Institute of Technology.

Affected versions

PyPI

PackageVulnerableFixed in
tensorflow
< 2.7.2
2.7.2
tensorflow
>= 2.8.0, < 2.8.1
2.8.1
tensorflow
>= 2.9.0, < 2.9.1
2.9.1
tensorflow
< 2.7.2
>= 2.8.0, < 2.8.1
>= 2.9.0, < 2.9.1
2.7.2
2.8.1
2.9.1
tensorflow-cpu
< 2.7.2
2.7.2
tensorflow-cpu
>= 2.8.0, < 2.8.1
2.8.1
tensorflow-cpu
>= 2.9.0, < 2.9.1
2.9.1
tensorflow-cpu
< 2.7.2
>= 2.8.0, < 2.8.1
>= 2.9.0, < 2.9.1
2.7.2
2.8.1
2.9.1
tensorflow-gpu
< 2.7.2
2.7.2
tensorflow-gpu
>= 2.8.0, < 2.8.1
2.8.1
tensorflow-gpu
>= 2.9.0, < 2.9.1
2.9.1
tensorflow-gpu
< 2.7.2
>= 2.8.0, < 2.8.1
>= 2.9.0, < 2.9.1
2.7.2
2.8.1
2.9.1

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

tensorflow PyPI → 2.7.2

pip
pip install --upgrade "tensorflow>=2.7.2"
poetry
poetry add "tensorflow>=2.7.2"
uv
uv add "tensorflow>=2.7.2"

tensorflow-cpu PyPI → 2.7.2

pip
pip install --upgrade "tensorflow-cpu>=2.7.2"
poetry
poetry add "tensorflow-cpu>=2.7.2"
uv
uv add "tensorflow-cpu>=2.7.2"

tensorflow-gpu PyPI → 2.7.2

pip
pip install --upgrade "tensorflow-gpu>=2.7.2"
poetry
poetry add "tensorflow-gpu>=2.7.2"
uv
uv add "tensorflow-gpu>=2.7.2"

Severity breakdown

CVSS 3.1 5.9

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Attack vector
Network
Attack complexity
High
Privileges required
None
User interaction
None
Scope
Unchanged
Confidentiality
None
Integrity
None
Availability
High

Weakness

CWE-476: NULL Pointer Dereference

The product dereferences a pointer that it expects to be valid but is NULL.

How to prevent it
  • Implementation: For any pointers that could have been modified or provided from a function that can return NULL, check the pointer for NULL before use. When working with a multithreaded or otherwise asynchronous environment, ensure that proper locking APIs are used to lock before the check, and unlock when it has finished [REF-1484].
  • Requirements: Select a programming language that is not susceptible to these issues.
  • Implementation: Check the results of all functions that return a value and verify that the value is non-null before acting upon it.
  • Architecture and Design: Identify all variables and data stores that receive information from external sources, and apply input validation to make sure that they are only initialized to expected values.
  • Implementation: Explicitly initialize all variables and other data stores, either during declaration or just before the first usage.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-gjh7-xx4r-x345
TensorFlow has segfault in array_ops.upper_bound
High Also affects tensorflow
GHSA-fxgc-95xx-grvq
TensorFlow Denial of Service vulnerability
Medium Also affects tensorflow
GHSA-93vr-9q9m-pj8p
TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
High Also affects tensorflow
GHSA-qjqc-vqcf-5qvj
TensorFlow vulnerable to seg fault in `tf.raw_ops.Print`
High Also affects tensorflow
GHSA-7jvm-xxmr-v5cw
TensorFlow vulnerable to integer overflow in EditDistance
High Also affects tensorflow
GHSA-64jg-wjww-7c5w
TensorFlow has Null Pointer Error in TensorArrayConcatV2
High Also affects tensorflow
GHSA-6hg6-5c2q-7rcr
TensorFlow has Heap-buffer-overflow in AvgPoolGrad
High Also affects tensorflow
GHSA-558h-mq8x-7q9g
TensorFlow has Null Pointer Error in SparseSparseMaximum
High Also affects tensorflow
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor