GHSA-fc75-58r8-rm3h CVE-2023-45809 PYSEC-2023-219
Wagtail vulnerable to disclosure of user names via admin bulk action views
- Severity
- 2.7 / 10
- Low · CVSS 3.1
- Exploit chance (EPSS)
- 0.56%
- Chance of exploitation in the next 30 days. Higher than 46.30% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- CWE-425 Direct Request ('Forced Browsing')
- CWE-532 Insertion of Sensitive Information into Log File
- Fix
4.1.9- Upgrade wagtail to this version or later
Description
Impact
A user with a limited-permission editor account for the Wagtail admin can make a direct URL request to the admin view that handles bulk actions on user accounts. While authentication rules prevent the user from making any changes, the error message discloses the display names of user accounts, and by modifying URL parameters, the user can retrieve the display name for any user. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin.
Patches
Patched versions have been released as Wagtail 4.1.9 (LTS), 5.0.5 and 5.1.3. The fix is also included in Release Candidate 1 of the forthcoming Wagtail 5.2 release.
Workarounds
None.
Acknowledgements
Many thanks to @quyenheu for reporting this issue.
For more information
If you have any questions or comments about this advisory:
- Visit Wagtail's support channels
- Email us at security@wagtail.org (view our security policy for more information).
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| wagtail | < 4.1.9 |
4.1.9 |
| wagtail | >= 4.2.0, < 5.0.5 |
5.0.5 |
| wagtail | >= 5.1.0, < 5.1.3 |
5.1.3 |
| wagtail | < 4.1.9>= 4.2, < 5.0.5>= 5.1, < 5.1.3 |
4.1.95.0.55.1.3 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
wagtail PyPI → 4.1.9
- pip
pip install --upgrade "wagtail>=4.1.9"- poetry
poetry add "wagtail>=4.1.9"- uv
uv add "wagtail>=4.1.9"
Severity breakdown
CVSS 3.1 2.7
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- High
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
CWE-425: Direct Request ('Forced Browsing')
The web application does not adequately enforce appropriate authorization on all restricted URLs, scripts, or files.
How to prevent it
- Architecture and Design, Operation: Apply appropriate access control authorizations for each access to all restricted URLs, scripts or files.
- Architecture and Design: Consider using MVC based frameworks such as Struts.
CWE-532: Insertion of Sensitive Information into Log File
The product writes sensitive information to a log file.
How to prevent it
- Architecture and Design, Implementation: Consider seriously the sensitivity of the information written into log files. Do not write secrets into the log files.
- Distribution: Remove debug log files before deploying the application into production.
- Operation: Protect log files against unauthorized read/write.
- Implementation: Adjust configurations appropriately when software is transitioned from a debug state to production.
References
Advisories
Packages
Other links
- github.com/wagtail/wagtail/security/advisories/GHSA-fc75-58r8-rm3h
- github.com/wagtail/wagtail/commit/0bacd29473107d9d7f5b723a15a683449679756d
- github.com/wagtail/wagtail/commit/2231f462c75dfe84307fb40577e8c2109a23b27e
- github.com/wagtail/wagtail/commit/bc96aed6ac53f998b2f4c4bf97e2d4f5fe337e5b
- github.com/pypa/advisory-database/tree/main/vulns/wagtail/PYSEC-2023-219.yaml
- github.com/wagtail/wagtail/releases/tag/v4.1.9
- github.com/wagtail/wagtail/releases/tag/v5.0.5
- github.com/wagtail/wagtail/releases/tag/v5.1.3
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-jm5p-837g-rv8g Wagtail: Improper restriction handling on Page translation API endpoint | Medium | Also affects wagtail |
| GHSA-x5cx-w6p2-mxf2 Wagtail: Improper permission handling when copying snippets | Medium | Also affects wagtail |
| GHSA-c2xx-cjmh-9q8f Wagtail: Improper restriction handling on descendant collections in Documents and Images API | Medium | Also affects wagtail |
| GHSA-92hv-j533-69wc Wagtail: Identification of documents by SHA1 hash | Low | Also affects wagtail |
| GHSA-3vrh-m9w7-v94f Wagtail: Improper restriction handling on Pages admin API | Medium | Also affects wagtail |
| GHSA-23m2-mghx-vqmf Wagtail: Reflected XSS in dynamic image URL generator view | High | Also affects wagtail |
| GHSA-8634-mr4j-r72c Wagtail: Pages translations can be created without page permissions when using simple_translation | Medium | Also affects wagtail |
| GHSA-r6p4-grq7-xm4m Wagtail: Improper permission handling in image preview | Medium | Also affects wagtail |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor