GHSA-f73h-224c-62qr CVE-2019-8151
Magento Server-Side Request Forgery (SSRF)
- Severity
- 7.2 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 1.71%
- Chance of exploitation in the next 30 days. Higher than 77.40% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-918 Server-Side Request Forgery (SSRF)
- Fix
2.2.10- Upgrade magento/community-edition to this version or later
Description
A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to manipulate shippment settings can execute arbitrary code through server-side request forgery due to unsafe handling of a carrier gateway.
As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
Affected versions
Packagist
| Package | Vulnerable | Fixed in |
|---|---|---|
| magento/community-edition | >= 2.2.0, < 2.2.10 |
2.2.10 |
| magento/community-edition | >= 2.3.0, < 2.3.2-p2 |
2.3.2-p2 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
magento/community-edition Packagist → 2.2.10
- composer
composer require magento/community-edition:^2.2.10
Severity breakdown
CVSS 3.1 7.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- High
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-918: Server-Side Request Forgery (SSRF)
The web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-wh92-6q6g-px7j Magento Community Edition Improper Input Validation vulnerability | Critical Known exploited | Also affects magento/community-edition |
| GHSA-m8cj-3v68-3cxj Magento Open Source affected by an Improper Restriction of XML External Entity Reference ('XXE') vulnerability | Critical Known exploited | Also affects magento/community-edition |
| GHSA-f8fv-f786-9933 Magento improper input validation vulnerability | Critical Known exploited | Also affects magento/community-edition |
| GHSA-qvwr-p3hj-j6jf Magento vulnerable to privilege escalation due to incorrect authorization | Medium | Also affects magento/community-edition |
| GHSA-pcrx-r49h-x2w5 Magento vulnerable to stored Cross-Site Scripting (XSS) | Medium | Also affects magento/community-edition |
| GHSA-r355-75hw-r8jf Magento allows incorrect authorization | Medium | Also affects magento/community-edition |
| GHSA-2768-5wmv-cfff Magento vulnerable to stored Cross-Site Scripting (XSS) | High | Also affects magento/community-edition |
| GHSA-69x9-xp2j-w8g8 Magento provides incorrect authorization through a security feature bypass | High | Also affects magento/community-edition |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor