GHSA-f4qf-m5gf-8jm8 BIT-tomcat-2024-21733 CVE-2024-21733
Apache Tomcat vulnerable to Generation of Error Message Containing Sensitive Information
- Severity
- 5.3 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 14.29%
- Chance of exploitation in the next 30 days. Higher than 96.60% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-209 Generation of Error Message Containing Sensitive Information
- Fix
- Available
- 3 packages have a fixed version
Description
Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43.
Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | >= 8.5.7, < 8.5.64 |
8.5.64 |
| org.apache.tomcat.embed:tomcat-embed-core | >= 9.0.0-M11, < 9.0.44 |
9.0.44 |
| org.apache.tomcat.experimental:tomcat-embed-programmatic | >= 9.0.43, < 9.0.44 |
9.0.44 |
| org.apache.tomcat:tomcat-coyote | >= 9.0.0-M11, < 9.0.44 |
9.0.44 |
| org.apache.tomcat:tomcat-coyote | >= 8.5.7, < 8.5.64 |
8.5.64 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.tomcat.embed:tomcat-embed-core Maven → 8.5.64
- maven
<dependency><groupId>org.apache.tomcat.embed</groupId><artifactId>tomcat-embed-core</artifactId><version>8.5.64</version></dependency>- gradle
implementation("org.apache.tomcat.embed:tomcat-embed-core:8.5.64")
org.apache.tomcat.experimental:tomcat-embed-programmatic Maven → 9.0.44
- maven
<dependency><groupId>org.apache.tomcat.experimental</groupId><artifactId>tomcat-embed-programmatic</artifactId><version>9.0.44</version></dependency>- gradle
implementation("org.apache.tomcat.experimental:tomcat-embed-programmatic:9.0.44")
org.apache.tomcat:tomcat-coyote Maven → 9.0.44
- maven
<dependency><groupId>org.apache.tomcat</groupId><artifactId>tomcat-coyote</artifactId><version>9.0.44</version></dependency>- gradle
implementation("org.apache.tomcat:tomcat-coyote:9.0.44")
Severity breakdown
CVSS 3.1 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Weakness
CWE-209: Generation of Error Message Containing Sensitive Information
The product generates an error message that includes sensitive information about its environment, users, or associated data.
How to prevent it
- Implementation: Ensure that error messages only contain minimal details that are useful to the intended audience and no one else. The messages need to strike the balance between being too cryptic (which can confuse users) or being too detailed (which may reveal more than intended). The messages should not reveal the methods that were used to determine the error. Attackers can use detailed information to refine or optimize their original attack, thereby increasing their chances of success. If errors must be captured in some detail, record them in log messages, but consider what could occur if the log messages can be viewed by attackers. Highly sensitive information such as passwords should never be saved to log files. Avoid inconsistent messaging that might accidentally tip off an attacker about internal state, such as whether a user account exists or not.
- Implementation: Handle exceptions internally and do not display errors containing potentially sensitive information to a user.
- Implementation: Use naming conventions and strong types to make it easier to spot when sensitive data is being used. When creating structures, objects, or other complex entities, separate the sensitive and non-sensitive data as much as possible.
- Implementation, Build and Compilation: Debugging information should not make its way into a production release.
- Implementation, Build and Compilation: Debugging information should not make its way into a production release.
- System Configuration: Where available, configure the environment to use less verbose error messages. For example, in PHP, disable the display_errors setting during configuration, or at runtime using the error_reporting() function.
- System Configuration: Create default error pages or messages that do not leak any information.
References
Advisories
Packages
Other links
- github.com/apache/tomcat/commit/86ccc43940861703c2be96a5f35384407522125a
- github.com/apache/tomcat/commit/ce4b154e7b48f66bd98858626347747cd2514311
- lists.apache.org/thread/h9bjqdd0odj6lhs2o96qgowcc6hb0cfz
- lists.debian.org/debian-lts-announce/2025/01/msg00009.html
- security.netapp.com/advisory/ntap-20240216-0005
- tomcat.apache.org/security-8.html
- tomcat.apache.org/security-9.html
- packetstormsecurity.com/files/176951/Apache-Tomcat-8.5.63-9.0.43-HTTP-Response-Smuggling.html
- openwall.com/lists/oss-security/2024/01/19/2
- security.netapp.com/advisory/ntap-20240216-0005
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-83qj-6fr2-vhqg Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT | Critical Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-qppj-fm5r-hxr3 HTTP/2 Stream Cancellation Attack | Medium Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-xjgh-84hx-56c5 Unrestricted Upload of File with Dangerous Type Apache Tomcat | High Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| CVE-2020-1938 Improper Privilege Management in Tomcat | Critical Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-pjfr-qf3p-3q25 When running Apache Tomcat on Windows with HTTP PUTs enabled it was possible to upload a JSP file to the server | High Known exploited | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-h3x4-894j-xpx5 Apache Tomcat's FORM authentication process has an Incorrect Authorization vulnerability | Critical | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-9xv2-5v5q-p794 Apache Tomcat's DIGEST authenticator has an Authentication Bypass by Capture-replay vulnerability | Critical | Also affects org.apache.tomcat.embed:tomcat-embed-core |
| GHSA-f525-44xv-f2qj Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation | Critical | Also affects org.apache.tomcat.embed:tomcat-embed-core |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor