GHSA-cqvq-fvhr-v6hc
`CHECK` failure in `SobolSample` via missing validation
- Severity
- Low
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- —
- No score published
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- —
- Not classified
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
Another instance of CVE-2022-35935, where SobolSample is vulnerable to a denial of service via assumed scalar inputs, was found and fixed.
import tensorflow as tf
tf.raw_ops.SobolSample(dim=tf.constant([1,0]), num_results=tf.constant([1]), skip=tf.constant([1]))
Patches
We have patched the issue in GitHub commits c65c67f88ad770662e8f191269a907bf2b94b1bf and 02400ea266bd811fc016a848445de1bbff3a23a0
The fix will be included in TensorFlow 2.11. We will also cherrypick both commits on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range. TensorFlow 2.7.4 will have the first commit cherrypicked.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by:
- Kang Hong Jin from Singapore Management University
- Neophytos Christou, Secure Systems Labs, Brown University
- 刘力源, Information System & Security and Countermeasures Experiments Center, Beijing Institute of Technology
- Pattarakrit Rattankul
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.8.4 |
2.8.4 |
| tensorflow | >= 2.9.0, < 2.9.3 |
2.9.3 |
| tensorflow | >= 2.10.0, < 2.10.1 |
2.10.1 |
| tensorflow-cpu | < 2.8.4 |
2.8.4 |
| tensorflow-cpu | >= 2.9.0, < 2.9.3 |
2.9.3 |
| tensorflow-cpu | >= 2.10.0, < 2.10.1 |
2.10.1 |
| tensorflow-gpu | < 2.8.4 |
2.8.4 |
| tensorflow-gpu | >= 2.9.0, < 2.9.3 |
2.9.3 |
| tensorflow-gpu | >= 2.10.0, < 2.10.1 |
2.10.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.8.4
- pip
pip install --upgrade "tensorflow>=2.8.4"- poetry
poetry add "tensorflow>=2.8.4"- uv
uv add "tensorflow>=2.8.4"
tensorflow-cpu PyPI → 2.8.4
- pip
pip install --upgrade "tensorflow-cpu>=2.8.4"- poetry
poetry add "tensorflow-cpu>=2.8.4"- uv
uv add "tensorflow-cpu>=2.8.4"
tensorflow-gpu PyPI → 2.8.4
- pip
pip install --upgrade "tensorflow-gpu>=2.8.4"- poetry
poetry add "tensorflow-gpu>=2.8.4"- uv
uv add "tensorflow-gpu>=2.8.4"
References
Packages
Other links
Timeline
- Published
- Last updated by the source
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor