GHSA-cpf4-wx82-gxp6 BIT-tensorflow-2021-41222 CVE-2021-41222 PYSEC-2021-414 PYSEC-2021-631 PYSEC-2021-829
Segfault due to negative splits in `SplitV`
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 0.19%
- Chance of exploitation in the next 30 days. Higher than 8.39% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-682 Incorrect Calculation
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
The implementation of SplitV can trigger a segfault is an attacker supplies negative arguments:
import tensorflow as tf
tf.raw_ops.SplitV(
value=tf.constant([]),
size_splits=[-1, -2]
,axis=0,
num_split=2)
This occurs whenever size_splits contains more than one value and at least one value is negative.
Patches
We have patched the issue in GitHub commit 25d622ffc432acc736b14ca3904177579e733cc6.
The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by members of the Aivul Team from Qihoo 360.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow | < 2.4.4 |
2.4.4 |
| tensorflow | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
| tensorflow-cpu | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow-cpu | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow-cpu | < 2.4.4 |
2.4.4 |
| tensorflow-cpu | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
| tensorflow-gpu | >= 2.6.0, < 2.6.1 |
2.6.1 |
| tensorflow-gpu | >= 2.5.0, < 2.5.2 |
2.5.2 |
| tensorflow-gpu | < 2.4.4 |
2.4.4 |
| tensorflow-gpu | < 2.4.4>= 2.5.0, < 2.5.2>= 2.6.0, < 2.6.1>= 2.7.0rc0, < 2.7.0 |
2.4.42.5.22.6.12.7.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.6.1
- pip
pip install --upgrade "tensorflow>=2.6.1"- poetry
poetry add "tensorflow>=2.6.1"- uv
uv add "tensorflow>=2.6.1"
tensorflow-cpu PyPI → 2.6.1
- pip
pip install --upgrade "tensorflow-cpu>=2.6.1"- poetry
poetry add "tensorflow-cpu>=2.6.1"- uv
uv add "tensorflow-cpu>=2.6.1"
tensorflow-gpu PyPI → 2.6.1
- pip
pip install --upgrade "tensorflow-gpu>=2.6.1"- poetry
poetry add "tensorflow-gpu>=2.6.1"- uv
uv add "tensorflow-gpu>=2.6.1"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Local
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 5.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-682: Incorrect Calculation
The product performs a calculation that generates incorrect or unintended results that are later used in security-critical decisions or resource management.
How to prevent it
- Implementation: Understand your programming language's underlying representation and how it interacts with numeric calculation. Pay close attention to byte size discrepancies, precision, signed/unsigned distinctions, truncation, conversion and casting between types, "not-a-number" calculations, and how your language handles numbers that are too large or too small for its underlying representation.
- Implementation: Perform input validation on any numeric input by ensuring that it is within the expected range. Enforce that the input meets both the minimum and maximum requirements for the expected range.
- Implementation: Use the appropriate type for the desired action. For example, in C/C++, only use unsigned types for values that could never be negative, such as height, width, or other numbers related to quantity.
- Architecture and Design: Use languages, libraries, or frameworks that make it easier to handle numbers without unexpected consequences. Examples include safe integer handling packages such as SafeInt (C++) or IntegerLib (C or C++).
- Architecture and Design: Use languages, libraries, or frameworks that make it easier to handle numbers without unexpected consequences. Examples include safe integer handling packages such as SafeInt (C++) or IntegerLib (C or C++).
- Implementation: Examine compiler warnings closely and eliminate problems with potential security implications, such as signed / unsigned mismatch in memory operations, or use of uninitialized variables. Even if the weakness is rarely exploitable, a single failure may lead to the compromise of the entire system.
References
Advisories
Packages
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-cpf4-wx82-gxp6
- github.com/tensorflow/tensorflow/commit/25d622ffc432acc736b14ca3904177579e733cc6
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-631…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-829…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-414.yaml
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor