GHSA-cj2h-ww36-v932 CVE-2020-7956 GO-2022-0821
Improper Certificate Validation in HashiCorp Nomad
- Severity
- 9.8 / 10
- Critical · CVSS 3.1
- Exploit chance (EPSS)
- 0.98%
- Chance of exploitation in the next 30 days. Higher than 62.33% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-295 Improper Certificate Validation
- Fix
0.10.3- Upgrade github.com/hashicorp/nomad to this version or later
Description
HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region associated with TLS certificates used for mTLS RPC, and were susceptible to privilege escalation. Fixed in 0.10.3.
Affected versions
Go
| Package | Vulnerable | Fixed in |
|---|---|---|
| github.com/hashicorp/nomad | < 0.10.3 |
0.10.3 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
github.com/hashicorp/nomad Go → 0.10.3
- go
go get github.com/hashicorp/nomad@v0.10.3 && go mod tidy
Severity breakdown
CVSS 3.1 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-295: Improper Certificate Validation
The product does not validate, or incorrectly validates, a certificate.
How to prevent it
- Architecture and Design, Implementation: Certificates should be carefully managed and checked to assure that data are encrypted with the intended owner's public key.
- Implementation: If certificate pinning is being used, ensure that all relevant properties of the certificate are fully validated before the certificate is pinned, including the hostname.
References
Advisories
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-hx53-77qj-8663 HashiCorp Nomad vulnerable to a path traversal | High | Also affects github.com/hashicorp/nomad |
| GHSA-3934-423w-4jq3 HashiCorp Nomad vulnerable to symlink attack | Medium | Also affects github.com/hashicorp/nomad |
| GHSA-rx97-6c62-55mf Hashicorp Nomad Incorrect Privilege Assignment vulnerability | High | Also affects github.com/hashicorp/nomad |
| GHSA-c3q9-q986-vrwh Nomad is vulnerable to unintentional exposure of the workload identity token and client secret token in audit logs | Medium | Also affects github.com/hashicorp/nomad |
| GHSA-hr68-hvgv-xxqf Hashicorp Nomad Incorrect Privilege Assignment vulnerability | Medium | Also affects github.com/hashicorp/nomad |
| GHSA-2w5v-x29g-jw7j Hashicorp Nomad Incorrect Authorization vulnerability | High | Also affects github.com/hashicorp/nomad |
| GHSA-25qx-vfw2-fw8r Nomad Vulnerable to Allocation Directory Escape On Non-Existing File Paths Through Archive Unpacking | Medium | Also affects github.com/hashicorp/nomad |
| GHSA-5mqx-rpxv-mvxj HashiCorp Nomad is vulnerable to path escape through archive unpacking during migration | High | Also affects github.com/hashicorp/nomad |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor