GHSA-c6ph-m8cw-rfqh CVE-2023-38677 PYSEC-2024-132
PaddlePaddle floating point exception in paddle.linalg.eig
High
PyPI
- Severity
- 4.7 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 0.49%
- Chance of exploitation in the next 30 days. Higher than 42.03% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-369 Divide By Zero
- Fix
2.6.0- Upgrade paddlepaddle to this version or later
Description
FPE in paddle.linalg.eig in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| paddlepaddle | < 2.6.0 |
2.6.0 |
| paddlepaddle | < 2.6.0 |
2.6.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
paddlepaddle PyPI → 2.6.0
- pip
pip install --upgrade "paddlepaddle>=2.6.0"- poetry
poetry add "paddlepaddle>=2.6.0"- uv
uv add "paddlepaddle>=2.6.0"
Severity breakdown
CVSS 3.1 4.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Changed
- Confidentiality
- None
- Integrity
- None
- Availability
- Low
Weakness
CWE-369: Divide By Zero
The product divides a value by zero.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-jwrc-3v3f-5cq5 PaddlePaddle allows arbitrary file read via paddle.vision.ops.read_file | High | Also affects paddlepaddle |
| GHSA-2rp8-hff9-c5wr PaddlePaddle Path Traversal vulnerability | Critical | Also affects paddlepaddle |
| GHSA-mrmm-qmrj-xgp6 PaddlePaddle vulnerable to remote code execution | Critical | Also affects paddlepaddle |
| GHSA-qqv2-35q8-p2g2 PaddlePaddle command injection in paddle.utils.download._wget_download | High | Also affects paddlepaddle |
| GHSA-fh54-3vhg-mpc2 PaddlePaddle command injection vulnerability | High | Also affects paddlepaddle |
| GHSA-chj7-w3f6-cvfj Code Injection in paddlepaddle | High | Also affects paddlepaddle |
| GHSA-v9pg-qw6x-w5r2 PaddlePaddle floating point exception in paddle.amin | High | Also affects paddlepaddle |
| GHSA-x3q9-c788-j7c8 PaddlePaddle segfault in paddle.dot | High | Also affects paddlepaddle |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor