GHSA-9c8h-2mv3-49ww BIT-tensorflow-2021-37675 CVE-2021-37675 PYSEC-2021-297 PYSEC-2021-588 PYSEC-2021-786
Division by 0 in most convolution operators
- Severity
- 0.0 / 10
- Medium · CVSS 4.0
- Exploit chance (EPSS)
- 0.16%
- Chance of exploitation in the next 30 days. Higher than 5.13% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-369 Divide By Zero
- Fix
- Available
- 3 packages have a fixed version
Description
Impact
Most implementations of convolution operators in TensorFlow are affected by a division by 0 vulnerability where an attacker can trigger a denial of service via a crash:
import tensorflow as tf
tf.compat.v1.disable_v2_behavior()
tf.raw_ops.Conv2D(
input = tf.constant([], shape=[0, 0, 0, 0], dtype=tf.float32),
filter = tf.constant([], shape=[0, 0, 0, 0], dtype=tf.float32),
strides = [1, 1, 1, 1],
padding = "SAME")
The shape inference implementation is missing several validations before doing divisions and modulo operations.
Patches
We have patched the issue in GitHub commit 8a793b5d7f59e37ac7f3cd0954a750a2fe76bad4.
The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Yakun Zhang of Baidu Security.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| tensorflow | < 2.3.4 |
2.3.4 |
| tensorflow | >= 2.4.0, < 2.4.3 |
2.4.3 |
| tensorflow | >= 2.5.0, < 2.5.1 |
2.5.1 |
| tensorflow | >= 2.3.0, < 2.3.4>= 2.4.0, < 2.4.3 |
2.3.42.4.3 |
| tensorflow-cpu | < 2.3.4 |
2.3.4 |
| tensorflow-cpu | >= 2.4.0, < 2.4.3 |
2.4.3 |
| tensorflow-cpu | >= 2.5.0, < 2.5.1 |
2.5.1 |
| tensorflow-cpu | >= 2.3.0, < 2.3.4>= 2.4.0, < 2.4.3 |
2.3.42.4.3 |
| tensorflow-gpu | < 2.3.4 |
2.3.4 |
| tensorflow-gpu | >= 2.4.0, < 2.4.3 |
2.4.3 |
| tensorflow-gpu | >= 2.5.0, < 2.5.1 |
2.5.1 |
| tensorflow-gpu | >= 2.3.0, < 2.3.4>= 2.4.0, < 2.4.3 |
2.3.42.4.3 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
tensorflow PyPI → 2.3.4
- pip
pip install --upgrade "tensorflow>=2.3.4"- poetry
poetry add "tensorflow>=2.3.4"- uv
uv add "tensorflow>=2.3.4"
tensorflow-cpu PyPI → 2.3.4
- pip
pip install --upgrade "tensorflow-cpu>=2.3.4"- poetry
poetry add "tensorflow-cpu>=2.3.4"- uv
uv add "tensorflow-cpu>=2.3.4"
tensorflow-gpu PyPI → 2.3.4
- pip
pip install --upgrade "tensorflow-gpu>=2.3.4"- poetry
poetry add "tensorflow-gpu>=2.3.4"- uv
uv add "tensorflow-gpu>=2.3.4"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Attack vector
- Local
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- None
- Confidentiality (vulnerable system)
- None
- Integrity (vulnerable system)
- None
- Availability (vulnerable system)
- High
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 5.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-369: Divide By Zero
The product divides a value by zero.
References
Advisories
Other links
- github.com/tensorflow/tensorflow/security/advisories/GHSA-9c8h-2mv3-49ww
- github.com/tensorflow/tensorflow/commit/8a793b5d7f59e37ac7f3cd0954a750a2fe76bad4
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-588…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-786…
- github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-297.yaml
- github.com/tensorflow/tensorflow
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-gjh7-xx4r-x345 TensorFlow has segfault in array_ops.upper_bound | High | Also affects tensorflow |
| GHSA-fxgc-95xx-grvq TensorFlow Denial of Service vulnerability | Medium | Also affects tensorflow |
| GHSA-93vr-9q9m-pj8p TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch | High | Also affects tensorflow |
| GHSA-qjqc-vqcf-5qvj TensorFlow vulnerable to seg fault in `tf.raw_ops.Print` | High | Also affects tensorflow |
| GHSA-7jvm-xxmr-v5cw TensorFlow vulnerable to integer overflow in EditDistance | High | Also affects tensorflow |
| GHSA-64jg-wjww-7c5w TensorFlow has Null Pointer Error in TensorArrayConcatV2 | High | Also affects tensorflow |
| GHSA-6hg6-5c2q-7rcr TensorFlow has Heap-buffer-overflow in AvgPoolGrad | High | Also affects tensorflow |
| GHSA-558h-mq8x-7q9g TensorFlow has Null Pointer Error in SparseSparseMaximum | High | Also affects tensorflow |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor