Skip to content

GHSA-937f-qh3w-6g87 CVE-2022-2888 PYSEC-2022-282

OctoPrint vulnerable to Insufficient Session Expiration.

Medium PyPI
Severity
0.0 / 10
Medium · CVSS 4.0
Exploit chance (EPSS)
0.30%
Chance of exploitation in the next 30 days. Higher than 22.47% of scored vulnerabilities.
Known exploited
No
Not in CISA's catalog
Weakness
CWE-613 Insufficient Session Expiration
Fix
1.8.3
Upgrade octoprint to this version or later

Description

If an attacker comes into the possession of a victim's OctoPrint session cookie through whatever means, the attacker can use this cookie to authenticate as long as the victim's account exists. This issue is fixed in version 1.8.3.

Affected versions

PyPI

PackageVulnerableFixed in
octoprint
< 1.8.3
1.8.3
octoprint
< 1.8.3
1.8.3

How to fix

Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.

octoprint PyPI → 1.8.3

pip
pip install --upgrade "octoprint>=1.8.3"
poetry
poetry add "octoprint>=1.8.3"
uv
uv add "octoprint>=1.8.3"

Severity breakdown

CVSS 4.0 0.0

CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Attack vector
Network
Attack complexity
Low
Attack requirements
None
Privileges required
Low
User interaction
None
Confidentiality (vulnerable system)
Low
Integrity (vulnerable system)
Low
Availability (vulnerable system)
None
Confidentiality (subsequent systems)
None
Integrity (subsequent systems)
None
Availability (subsequent systems)
None

CVSS 3.1 4.4

CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Attack vector
Local
Attack complexity
Low
Privileges required
Low
User interaction
None
Scope
Unchanged
Confidentiality
Low
Integrity
Low
Availability
None

Weakness

CWE-613: Insufficient Session Expiration

According to WASC, "Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization."

How to prevent it
  • Implementation: Set sessions/credentials expiration date.

References

Timeline

  1. Published
  2. Last updated by the source
  3. Latest EPSS score
AdvisorySeverityWhy it's related
GHSA-j4h9-pm27-4rfw
OctoPrint has possible file exfiltration via query parameters on upload endpoints
High Also affects octoprint
GHSA-p6qx-ghxm-389h
OctoPrint has XSS in its Suppressed Command Notifications
Medium Also affects octoprint
GHSA-xg4x-w2j3-57h6
OctoPrint has Timing Side-Channel Vulnerability in API Key Authentication
Medium Also affects octoprint
GHSA-crvm-xjhm-9h29
OctoPrint vulnerable to XSS in Action Commands Notification and Prompt
Medium Also affects octoprint
GHSA-49mj-x8jp-qvfc
OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload
High Also affects octoprint
GHSA-9wj4-8h85-pgrw
OctoPrint Vulnerable to Denial of Service through malformed HTTP request in OctoPrint
Medium Also affects octoprint
GHSA-m9jh-jf9h-x3h2
OctoPrint vulnerable to possible file extraction via upload endpoints
Medium Also affects octoprint
GHSA-qw93-h6pf-226x
OctoPrint Authenticated Reverse Proxy Page Authentication Bypass
Medium Also affects octoprint
Is this in your code?

MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.

Check your repos with MergeHarbor