GHSA-923p-fr2c-g5m2 CVE-2020-1739 PYSEC-2020-11
Exposure of Sensitive Information to an Unauthorized Actor in Ansible
- Severity
- 0.0 / 10
- Low · CVSS 4.0
- Exploit chance (EPSS)
- 0.36%
- Chance of exploitation in the next 30 days. Higher than 29.97% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
- Fix
2.7.17- Upgrade ansible to this version or later
Description
A flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svn module, it is used on svn command line, disclosing to other users within the same node. An attacker could take advantage by reading the cmdline file from that particular PID on the procfs.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| ansible | < 2.7.17 |
2.7.17 |
| ansible | >= 2.8.0a1, < 2.8.11 |
2.8.11 |
| ansible | >= 2.9.0a1, < 2.9.7 |
2.9.7 |
| ansible | < 2.7.17>= 2.8.0, < 2.8.9>= 2.9.0, < 2.9.6 |
2.7.172.8.92.9.6 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
ansible PyPI → 2.7.17
- pip
pip install --upgrade "ansible>=2.7.17"- poetry
poetry add "ansible>=2.7.17"- uv
uv add "ansible>=2.7.17"
Severity breakdown
CVSS 4.0 0.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
- Attack vector
- Local
- Attack complexity
- Low
- Attack requirements
- None
- Privileges required
- Low
- User interaction
- Passive
- Confidentiality (vulnerable system)
- Low
- Integrity (vulnerable system)
- Low
- Availability (vulnerable system)
- None
- Confidentiality (subsequent systems)
- None
- Integrity (subsequent systems)
- None
- Availability (subsequent systems)
- None
CVSS 3.1 3.9
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Weakness
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
The product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
How to prevent it
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
References
Advisories
Packages
Other links
- github.com/ansible/ansible/issues/67797
- github.com/ansible/ansible/pull/68911
- github.com/ansible/ansible/pull/68912
- github.com/ansible/ansible/pull/68913
- github.com/ansible/ansible/commit/1a89d4f059c21a818306a39ada7f5284ae125237
- github.com/ansible/ansible/commit/6c74a298702c8bb5532b9600073312e08f39680f
- github.com/ansible/ansible/commit/c6c4fbf4a1fdea1e10ba94462a60c413990a16a4
- debian.org/security/2021/dsa-4950
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/U3IMV…
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QT27K…
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FWDK3…
- lists.debian.org/debian-lts-announce/2020/05/msg00005.html
- github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-11.yaml
- bugzilla.redhat.com/show_bug.cgi
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QT27K…
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FWDK3…
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/U3IMV…
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-8ggh-xwr9-3373 Ansible Community General Collection is vulnerable to exposure of sensitive information | Medium | Also affects ansible |
| GHSA-jpvw-p8pr-9g2x Ansible symlink attack vulnerability | Medium | Also affects ansible |
| GHSA-cpx3-93w7-457x Ansible leaks password to logs | High | Also affects ansible |
| GHSA-fh5v-5f35-2rv2 Insertion of Sensitive Information into Log File in ansible | Medium | Also affects ansible |
| GHSA-4r65-35qq-ch8j Ansible discloses sensitive information in traceback error message | Medium | Also affects ansible |
| GHSA-2pfh-q76x-gwvm Improper Input Validation and Command Injection in Ansible | High | Also affects ansible |
| PYSEC-2021-126 A flaw was found in Ansible if an ansible user sets ANSIBLE_ASYNC_DIR to a subdirectory of a world writable directory. | Not rated yet | Also affects ansible |
| GHSA-r6h7-5pq2-j77h Insufficiently random values in Ansible | Medium | Also affects ansible |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor