GHSA-8xww-x3g3-6jcv CVE-2023-22795
ReDoS based DoS vulnerability in Action Dispatch
- Severity
- Low
- The publisher's own rating, not a CVSS score
- Exploit chance (EPSS)
- 2.28%
- Chance of exploitation in the next 30 days. Higher than 83.12% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-1333 Inefficient Regular Expression Complexity
- Fix
6.1.7.1- Upgrade actionpack to this version or later
Description
There is a possible regular expression based DoS vulnerability in Action Dispatch related to the If-None-Match header. This vulnerability has been assigned the CVE identifier CVE-2023-22795.
Versions Affected: All Not affected: None Fixed Versions: 5.2.8.15 (Rails LTS), 6.1.7.1, 7.0.4.1
Impact
A specially crafted HTTP If-None-Match header can cause the regular expression engine to enter a state of catastrophic backtracking, when on a version of Ruby below 3.2.0. This can cause the process to use large amounts of CPU and memory, leading to a possible DoS vulnerability All users running an affected release should either upgrade or use one of the workarounds immediately. Releases
The FIXED releases are available at the normal locations. Workarounds
We recommend that all users upgrade to one of the FIXED versions. In the meantime, users can mitigate this vulnerability by using a load balancer or other device to filter out malicious If-None-Match headers before they reach the application.
Users on Ruby 3.2.0 or greater are not affected by this vulnerability. Patches
To aid users who aren’t able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset.
6-1-Avoid-regex-backtracking-on-If-None-Match-header.patch - Patch for 6.1 series
7-0-Avoid-regex-backtracking-on-If-None-Match-header.patch - Patch for 7.0 series
Please note that only the 7.0.Z and 6.1.Z series are supported at present, and 6.0.Z for severe vulnerabilities. Users of earlier unsupported releases are advised to upgrade as soon as possible as we cannot guarantee the continued availability of security fixes for unsupported releases.
Affected versions
RubyGems
| Package | Vulnerable | Fixed in |
|---|---|---|
| actionpack | >= 4.0.0.beta1, < 6.1.7.1 |
6.1.7.1 |
| actionpack | >= 7.0.0, < 7.0.4.1 |
7.0.4.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
actionpack RubyGems → 6.1.7.1
- bundler
bundle update actionpack # Gemfile: gem "actionpack", ">= 6.1.7.1"
Weakness
CWE-1333: Inefficient Regular Expression Complexity
The product uses a regular expression with a worst-case computational complexity that is inefficient and possibly exponential.
How to prevent it
- Architecture and Design: Use regular expressions that do not support backtracking, e.g. by removing nested quantifiers.
- System Configuration: Set backtracking limits in the configuration of the regular expression implementation, such as PHP's pcre.backtrack_limit. Also consider limits on execution time for the process.
- Implementation: Do not use regular expressions with untrusted input. If regular expressions must be used, avoid using backtracking in the expression.
- Implementation: Limit the length of the input that the regular expression will process.
References
Advisories
Packages
Other links
- github.com/rails/rails/commit/8d82687f3b04b2803320b64f985308239a8c3d2f
- github.com/rails/rails/commit/8dc45950619a4c64d16fb9370570c996d201f9b0
- github.com/rails/rails/commit/cd461c3e64e09cdcb1e379d1c35423c5e2caa592
- discuss.rubyonrails.org/t/cve-2023-22795-possible-redos-based-dos-vulnerability-in-action-di…
- github.com/rails/rails/releases/tag/v6.1.7.1
- github.com/rails/rails/releases/tag/v7.0.4.1
- github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2023-22795.yml
- rubyonrails.org/2023/1/17/Rails-Versions-6-0-6-1-6-1-7-1-7-0-4-1-have-been-released
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-6x85-j5j2-27jx actionpack Path Traversal vulnerability | High Known exploited | Also affects actionpack |
| GHSA-xrr4-p6fq-hjg7 Directory traversal vulnerability in Action View in Ruby on Rails | High Known exploited | Also affects actionpack |
| GHSA-pgm4-439c-5jp6 Rails has a possible XSS vulnerability in its Action Pack debug exceptions | Medium | Also affects actionpack |
| GHSA-vfm5-rmrh-j26v Possible Content Security Policy bypass in Action Dispatch | Low | Also affects actionpack |
| GHSA-vfg9-r3fq-jvx4 Possible ReDoS vulnerability in HTTP Token authentication in Action Controller | Medium | Also affects actionpack |
| GHSA-x76w-6vjr-8xgj Possible ReDoS vulnerability in query parameter filtering in Action Dispatch | Medium | Also affects actionpack |
| GHSA-fwhr-88qx-h9g7 Missing security headers in Action Pack on non-HTML responses | Critical | Also affects actionpack |
| GHSA-9822-6m93-xqf4 Rails has possible XSS Vulnerability in Action Controller | Medium | Also affects actionpack |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor