GHSA-8q9q-r9v2-644m CVE-2023-36468
Upgrading doesn't prevent exploiting vulnerable XWiki documents
- Severity
- 9.9 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 1.86%
- Chance of exploitation in the next 30 days. Higher than 79.25% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-459 Incomplete Cleanup
- Fix
14.10.7- Upgrade org.xwiki.platform:xwiki-platform-oldcore to this version or later
Description
Impact
When an XWiki installation is upgraded and that upgrade contains a fix for a bug in a document, just a new version of that document is added. In some cases, it's still possible to exploit the vulnerability that was fixed in the new version. The severity of this depends on the fixed vulnerability, for the purpose of this advisory take CVE-2022-36100 as example - it is easily exploitable with just view rights and critical. When XWiki is upgraded from a version before the fix for it (e.g., 14.3) to a version including the fix (e.g., 14.4), the vulnerability can still be reproduced by adding rev=1.1 to the URL used in the reproduction steps so remote code execution is possible even after upgrading. Therefore, this affects the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability also affects manually added script macros that contained security vulnerabilities that were later fixed by changing the script macro without deleting the versions with the security vulnerability from the history.
This vulnerability doesn't affect freshly installed versions of XWiki. Further, this vulnerability doesn't affect content that is only loaded from the current version of a document like the code of wiki macros or UI extensions.
Patches
This vulnerability has been patched in XWiki 14.10.7 and 15.2RC1 by forcing old revisions to be executed in a restricted mode that disables all script macros.
Workarounds
As a workaround, admins can manually delete old revisions of affected documents. A script could be used to identify all installed documents and delete the history for them. However, also manually added and later corrected code may be affected by this vulnerability so it is easy to miss documents.
References
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.xwiki.platform:xwiki-platform-oldcore | >= 2.0, < 14.10.7 |
14.10.7 |
| org.xwiki.platform:xwiki-platform-oldcore | >= 15.0-rc-1, < 15.2-rc-1 |
15.2-rc-1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.xwiki.platform:xwiki-platform-oldcore Maven → 14.10.7
- maven
<dependency><groupId>org.xwiki.platform</groupId><artifactId>xwiki-platform-oldcore</artifactId><version>14.10.7</version></dependency>- gradle
implementation("org.xwiki.platform:xwiki-platform-oldcore:14.10.7")
Severity breakdown
CVSS 3.1 9.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Changed
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-459: Incomplete Cleanup
The product does not properly "clean up" and remove temporary or supporting resources after they have been used.
How to prevent it
- Architecture and Design, Implementation: Temporary files and other supporting resources should be deleted/released immediately after they are no longer needed.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-qj4x-9g63-25g6 XWiki Platform Old Core: Resource path traversal via /skin/ action endpoint in Jetty 12+ | High | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-mrqg-xmgm-rc5g XWiki's REST APIs can list all pages/spaces, leading to unavailability | High | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-h259-74h5-4rh9 XWiki vulnerable to remote code execution with script right through unprotected Velocity scripting API | Critical | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-57q2-6cp4-9mq3 XWiki exposes passwords and emails stored in fields not named password/email in xml.vm | Medium | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-r38m-cgpg-qj69 XWiki leaks password hashes and other accessible password properties | Medium | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-p9qm-p942-q3w5 XWiki Platform vulnerable to SQL injection through XWiki#searchDocuments API | Critical | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-jp4x-w9cj-97q7 XWiki allows remote code execution through preview of XClass changes in AWM editor | High | Also affects org.xwiki.platform:xwiki-platform-oldcore |
| GHSA-prwh-7838-xf82 XWiki allows SQL injection in query endpoint of REST API with Oracle | Critical | Also affects org.xwiki.platform:xwiki-platform-oldcore |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor