GHSA-8f5j-mgx9-5hm5 BIT-superset-2022-45438 CVE-2022-45438 PYSEC-2026-778
Apache Superset has Improper Access Control
- Severity
- 5.3 / 10
- Medium · CVSS 3.1
- Exploit chance (EPSS)
- 1.27%
- Chance of exploitation in the next 30 days. Higher than 69.89% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Fix
2.0.1- Upgrade apache-superset to this version or later
Description
When explicitly enabling the feature flag DASHBOARD_CACHE (disabled by default), the system allowed for an unauthenticated user to access dashboard configuration metadata using a REST API Get endpoint. This issue affects Apache Superset version 1.5.2 and prior versions and version 2.0.0.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| apache-superset | <= 1.5.2 |
No fix yet |
| apache-superset | 1 listed versions | No fix yet |
| apache-superset | < 1.5.3>= 2.0.0, < 2.0.1 |
1.5.32.0.1 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
apache-superset PyPI → 2.0.1
- pip
pip install --upgrade "apache-superset>=2.0.1"- poetry
poetry add "apache-superset>=2.0.1"- uv
uv add "apache-superset>=2.0.1"
Severity breakdown
CVSS 3.1 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Weakness
CWE-284: Improper Access Control
The product does not restrict or incorrectly restricts access to a resource from an unauthorized actor.
How to prevent it
- Architecture and Design, Operation: Very carefully manage the setting, management, and handling of privileges. Explicitly manage trust zones in the software.
- Architecture and Design: Compartmentalize the system to have "safe" areas where trust boundaries can be unambiguously drawn. Do not allow sensitive data to go outside of the trust boundary and always be careful when interfacing with a compartment outside of the safe area. Ensure that appropriate compartmentalization is built into the system design, and the compartmentalization allows for and reinforces privilege separation functionality. Architects and designers should rely on the principle of least privilege to decide the appropriate time to use privileges and the time to drop privileges.
CWE-668: Exposure of Resource to Wrong Sphere
The product exposes a resource to the wrong control sphere, providing unintended actors with inappropriate access to the resource.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-5cx2-vq3h-x52c Apache superset missing check for default SECRET_KEY | Critical Known exploited | Also affects apache-superset |
| GHSA-mwf2-qr4v-94h2 Apache Superset: Read-Only Bypass via Improper Input Validation on PostgreSQL Connections | Medium | Also affects apache-superset |
| GHSA-h294-8fxm-m2pj Apache Superset allows authenticated users to view sensitive data without explicit permissions | Medium | Also affects apache-superset |
| GHSA-3m2g-v7jf-7fxc Apache Superset Improper Authorization allows low-privileged users to bypass access controls | Medium | Also affects apache-superset |
| GHSA-gvxg-9hqx-f4rg Apache Superset allows privileged users to conduct error-based SQL Injection | Medium | Also affects apache-superset |
| GHSA-48m2-v2r8-h23m Apache Superset: Incomplete DISALLOWED_SQL_FUNCTIONS default list for ClickHouse engine | Medium | Also affects apache-superset |
| GHSA-mhpq-m962-mg92 Apache Superset allows authenticated users to discover metadata about datasources they don't have permission to access | Medium | Also affects apache-superset |
| GHSA-fxgf-3xh6-m2pp Apache Superset has bypass of `DISALLOWED_SQL_FUNCTIONS` that allows execution of blocked SQL functions | Medium | Also affects apache-superset |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor