GHSA-89rj-5ggj-3p9p CVE-2018-5269 PYSEC-2026-2812 PYSEC-2026-703
Reachable Assertion in OpenCV.
- Severity
- 5.5 / 10
- Medium · CVSS 3.0
- Exploit chance (EPSS)
- 1.38%
- Chance of exploitation in the next 30 days. Higher than 72.19% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-617 Reachable Assertion
- Fix
- Available
- 2 packages have a fixed version
Description
In OpenCV 3.3.1 (corresponds with OpenCV-Python 3.3.1.11), an assertion failure happens in cv::RBaseStream::setPos in modules/imgcodecs/src/bitstrm.cpp because of an incorrect integer cast.
Affected versions
PyPI
| Package | Vulnerable | Fixed in |
|---|---|---|
| opencv-contrib-python | < 3.4.1.15 |
3.4.1.15 |
| opencv-python | < 3.4.1.15 |
3.4.1.15 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
opencv-contrib-python PyPI → 3.4.1.15
- pip
pip install --upgrade "opencv-contrib-python>=3.4.1.15"- poetry
poetry add "opencv-contrib-python>=3.4.1.15"- uv
uv add "opencv-contrib-python>=3.4.1.15"
opencv-python PyPI → 3.4.1.15
- pip
pip install --upgrade "opencv-python>=3.4.1.15"- poetry
poetry add "opencv-python>=3.4.1.15"- uv
uv add "opencv-python>=3.4.1.15"
Severity breakdown
CVSS 3.0 5.5
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- Attack vector
- Local
- Attack complexity
- Low
- Privileges required
- None
- User interaction
- Required
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Weakness
CWE-617: Reachable Assertion
The product contains an assert() or similar statement that can be triggered by an attacker, which leads to an application exit or other behavior that is more severe than necessary.
How to prevent it
- Implementation: Make sensitive open/close operation non reachable by directly user-controlled data (e.g. open/close resources)
- Implementation: Perform input validation on user data.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| PYSEC-2023-183 opencv-python versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. | High Known exploited | Also affects opencv-python |
| PYSEC-2023-181 opencv-contrib-python versions before v4.8.1.78 bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863. | High Known exploited | Also affects opencv-contrib-python |
| GHSA-qr4w-53vh-m672 opencv-python bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863 | High | Also affects opencv-python |
| GHSA-cxjf-x6jp-p7mc opencv-contrib-python bundled libwebp binaries in wheels that are vulnerable to CVE-2023-4863 | High | Also affects opencv-contrib-python |
| GHSA-9g8h-pjm4-q92p Out-of-bounds Write in OpenCV. | Medium | Also affects opencv-contrib-python |
| GHSA-q799-q27x-vp7w Out-of-bounds Write in OpenCV | High | Also affects opencv-contrib-python |
| GHSA-m6vm-8g8v-xfjh Out-of-bounds Write in OpenCV | High | Also affects opencv-contrib-python |
| GHSA-jggw-2q6g-c3m6 Out-of-bounds Read in OpenCV | Medium | Also affects opencv-contrib-python |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor