GHSA-89gw-cffj-mqg9 CVE-2022-45048
Apache Ranger code execution vulnerability in policy expressions
- Severity
- 8.8 / 10
- High · CVSS 3.1
- Exploit chance (EPSS)
- 1.13%
- Chance of exploitation in the next 30 days. Higher than 66.33% of scored vulnerabilities.
- Known exploited
- No
- Not in CISA's catalog
- Weakness
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
- Fix
2.4.0- Upgrade org.apache.ranger:ranger to this version or later
Description
Authenticated users with appropriate privileges can create policies having expressions that can exploit code execution vulnerability. This issue affects Apache Ranger: 2.3.0. Users are recommended to update to version 2.4.0.
Affected versions
Maven
| Package | Vulnerable | Fixed in |
|---|---|---|
| org.apache.ranger:ranger | >= 2.3.0, < 2.4.0 |
2.4.0 |
How to fix
Move to the fixed version or later with your package manager, update the lockfile, and run your tests. If the package only arrives through another dependency, upgrade that dependency first. If none of its releases pulls a fixed version yet, force the version with your package manager's override.
org.apache.ranger:ranger Maven → 2.4.0
- maven
<dependency><groupId>org.apache.ranger</groupId><artifactId>ranger</artifactId><version>2.4.0</version></dependency>- gradle
implementation("org.apache.ranger:ranger:2.4.0")
Severity breakdown
CVSS 3.1 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- Low
- User interaction
- None
- Scope
- Unchanged
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Weakness
CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')
The product constructs all or part of a command, data structure, or record using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify how it is parsed or interpreted when it is sent to a downstream component.
How to prevent it
- Requirements: Programming languages and supporting technologies might be chosen which are not subject to these issues.
- Implementation: Utilize an appropriate mix of allowlist and denylist parsing to filter control-plane syntax from all input.
References
Advisories
Packages
Other links
Timeline
- Published
- Last updated by the source
- Latest EPSS score
Related advisories
| Advisory | Severity | Why it's related |
|---|---|---|
| GHSA-6qc3-v8fv-fv9j Apache Ranger has a Command Injection vulnerability | Critical | Also affects org.apache.ranger:ranger |
| GHSA-g9gf-g5jq-9h3v Apache Ranger UI vulnerable to Server Side Request Forgery | Critical | Also affects org.apache.ranger:ranger |
| GHSA-vrx2-mgr9-v67h Apache Ranger has Stored Cross-site Scripting vulnerability in Edit Service Page | Medium | Also affects org.apache.ranger:ranger |
| GHSA-83m2-9g78-rrj4 Apache Ranger Cross-site Scripting vulnerability | Medium | Also affects org.apache.ranger:ranger |
| GHSA-7ccv-hhvc-62hg Apache Ranger allows users to bypass intended access restrictions via direct access to module URLs | High | Also affects org.apache.ranger:ranger |
| GHSA-qqg7-gcxw-gmj3 Apache Ranger allows users to bypass intended access restrictions via the REST API | Medium | Also affects org.apache.ranger:ranger |
| GHSA-22v7-w6c5-v4rr Apache Ranger Access Restriction Bypass | High | Also affects org.apache.ranger:ranger |
| GHSA-fpqp-v323-44xv Cross-site scripting in Apache Ranger | Medium | Also affects org.apache.ranger:ranger |
MergeHarbor checks every repository's dependencies against this database, ranks what matters by exploitability and reachability, routes it to the owning team and opens the fix pull request.
Check your repos with MergeHarbor